aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Williams <peterw@src.gnome.org>2000-06-26 07:00:29 +0800
committerPeter Williams <peterw@src.gnome.org>2000-06-26 07:00:29 +0800
commit78075bd090ddfe0824c6cd33faa2638ccd0e609e (patch)
tree831934e5a3282c2b0ba41023e495f6059f535543 /configure.in
parent902186dc5eff0f8472c467ecdf2895b220b678ff (diff)
downloadgsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.tar
gsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.tar.gz
gsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.tar.bz2
gsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.tar.lz
gsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.tar.xz
gsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.tar.zst
gsoc2013-evolution-78075bd090ddfe0824c6cd33faa2638ccd0e609e.zip
Force thread usage and clean up the configure aspect thereof.
svn path=/trunk/; revision=3734
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 11 insertions, 28 deletions
diff --git a/configure.in b/configure.in
index 28dfd9fcf2..7af7493057 100644
--- a/configure.in
+++ b/configure.in
@@ -136,43 +136,26 @@ dnl **************************************************
dnl * Posix thread support
dnl **************************************************
-have_pthread=false
+dnl Hah! Threads are no longer an option
+dnl AC_ARG_WITH(threads, [ --with-threads Include thread support],[
+dnl FIXME: support more thread types, pth at least
-AC_ARG_WITH(threads, [ --with-threads Include thread support],[
- if test x$withval = xyes; then
- test_thread=true
- else
- test_thread=false
- fi
-],[
- test_thread=false
-])
+GNOME_PTHREAD_CHECK
-if $test_thread; then
- GNOME_PTHREAD_CHECK
- if test "x$PTHREAD_LIB" = "x" ; then
- have_pthread=false
- else
- have_pthread=true
- fi
-else
- have_pthread=false
+if test "x$PTHREAD_LIB" = "x" ; then
+ AC_MSG_ERROR([POSIX threads are currently required for Evolution])
fi
-AM_CONDITIONAL(ENABLE_THREADS, $have_pthread)
-
dnl
dnl Notice that this is a hack, and we wont be able to use this forever, but
dnl at least for some time
dnl
-if $have_pthread; then
- THREADS_LIBS="$PTHREAD_LIB `glib-config --libs gthread`"
- THREADS_CFLAGS="`glib-config --cflags gthread`"
-else
- THREADS_LIBS=""
- THREADS_CFLAGS=""
-fi
+THREADS_LIBS="$PTHREAD_LIB `$GLIB_CONFIG --libs gthread`"
+THREADS_CFLAGS="`$GLIB_CONFIG --cflags gthread`"
+
+AC_SUBST(THREADS_LIBS)
+AC_SUBST(THREADS_CFLAGS)
dnl **************************************************
dnl * Print check