aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-01-25 11:17:54 +0800
committerArturo Espinosa <unammx@src.gnome.org>2000-01-25 11:17:54 +0800
commit32ce476a23e9f2757e9cc539532f38f4ab21837c (patch)
tree4a9aeebfe355427fe035d27441b02bbc7be0bc4d /configure.in
parent50e5c22f0f5c4083ceee623b5bc02a6a7fc4f18c (diff)
downloadgsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.gz
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.bz2
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.lz
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.xz
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.tar.zst
gsoc2013-evolution-32ce476a23e9f2757e9cc539532f38f4ab21837c.zip
Added the gnome-pilot and capplet checks; they will likely be reworked for
2000-01-24 Federico Mena Quintero <federico@helixcode.com> * configure.in: Added the gnome-pilot and capplet checks; they will likely be reworked for the Evolution framework, but for now the calendar/ directory needs them. * configure.in: Added checks for gnome-vfs. 2000-01-24 Federico Mena Quintero <federico@helixcode.com> * tlacuache.c: New main module for the Tlacuache personal calendar server. * tlacuache.gnorba: New gnorba file for Tlacuache, the GNOME personal calendar server. * Makefile.am: Added the stuff necessary to build Tlacuache. * cal.c (Cal_get_uri): Convert the URI to a string before returning it. * cal-factory.c (CalFactory_create): Doh, this function is void. * job.c (job_add): Use g_idle_add(), not gtk_idle_add(). svn path=/trunk/; revision=1623
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 30 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1ecda63d3a..8c2436f70e 100644
--- a/configure.in
+++ b/configure.in
@@ -23,7 +23,7 @@ AM_MAINTAINER_MODE
AC_CANONICAL_HOST
AM_ACLOCAL_INCLUDE(macros)
-GNOME_INIT
+GNOME_INIT(capplet)
GNOME_COMPILE_WARNINGS
AC_ISC_POSIX
AC_PROG_CC
@@ -119,10 +119,37 @@ EXTRA_GNOME_CFLAGS_THREADS="`gnome-config --cflags gnomeui libglade gdk_pixbuf g
AC_SUBST(EXTRA_GNOME_LIBS_THREADS)
AC_SUBST(EXTRA_GNOME_CFLAGS_THREADS)
+BONOBO_VFS_GNOME_LIBS="`gnome-config --libs gnomeui bonobo libglade gdk_pixbuf gnomecanvaspixbuf vfs `"
+BONOBO_VFS_GNOME_CFLAGS="`gnome-config --cflags gnomeui bonobo libglade gdk_pixbuf gnomecanvaspixbuf vfs `"
+AC_SUBST(BONOBO_VFS_GNOME_LIBS)
+AC_SUBST(BONOBO_VFS_GNOME_CFLAGS)
+
+dnl ******************************
+dnl Pilot checking
+dnl ******************************
+GNOME_PILOT_CHECK
+
+dnl ******************************
+dnl Gnome-VFS checking
+dnl ******************************
+AC_MSG_CHECKING(for GNOME-VFS)
+if gnome-config --libs vfs > /dev/null 2>&1; then
+ vfs_ok=true
+else
+ vfs_ok=false
+fi
+
+if $vfs_ok; then
+ AC_MSG_RESULT(found)
+else
+ AC_MSG_ERROR(GNOME-VFS is required to compile Evolution)
+fi
AC_ARG_WITH(camel-hard-log-level, [ --with-camel-hard-log-level=level value of log level in camel (0-10)],
camel_hard_log_level="$withval", camel_hard_log_level="0")
AC_DEFINE_UNQUOTED(CAMEL_HARD_LOG_LEVEL, $camel_hard_log_level)
+
+AC_SUBST(CAPPLET_LIBS)
AC_OUTPUT([
Makefile
@@ -151,4 +178,6 @@ mail/Makefile
data/Makefile
libversit/Makefile
calendar/Makefile
+calendar/doc/Makefile
+calendar/doc/C/Makefile
])