aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-07-13 07:10:48 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-07-13 07:10:48 +0800
commitf9eb656383a6b45b838cc597681347a70d796ceb (patch)
tree1d1e62f8a643b8c35abcac81059459fa135cef4a /configure.in
parent86236d06877132bb0586106f21cb61147e369503 (diff)
downloadgsoc2013-evolution-f9eb656383a6b45b838cc597681347a70d796ceb.tar
gsoc2013-evolution-f9eb656383a6b45b838cc597681347a70d796ceb.tar.gz
gsoc2013-evolution-f9eb656383a6b45b838cc597681347a70d796ceb.tar.bz2
gsoc2013-evolution-f9eb656383a6b45b838cc597681347a70d796ceb.tar.lz
gsoc2013-evolution-f9eb656383a6b45b838cc597681347a70d796ceb.tar.xz
gsoc2013-evolution-f9eb656383a6b45b838cc597681347a70d796ceb.tar.zst
gsoc2013-evolution-f9eb656383a6b45b838cc597681347a70d796ceb.zip
Make gnome-print-0.20 mandatory. We will bail out with CVS HEAD versions
2000-07-12 Federico Mena Quintero <federico@helixcode.com> * configure.in: Make gnome-print-0.20 mandatory. We will bail out with CVS HEAD versions to avoid breakage. svn path=/trunk/; revision=4129
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 4e90fec199..da4f2523e8 100644
--- a/configure.in
+++ b/configure.in
@@ -193,17 +193,16 @@ fi
dnl **************************************************
dnl * Print check
dnl **************************************************
-AC_MSG_CHECKING(for GnomePrint libraries >= 0.20)
+AC_MSG_CHECKING(for GnomePrint libraries version 0.20)
if gnome-config --libs print > /dev/null 2>&1; then
- vers=`gnome-config --modversion print | sed -e "s/gnome-print-//" | \
- awk 'BEGIN { FS = "."; } { print $1 * 1000 + $2;}'`
- if test "$vers" -ge 13; then
+ vers=`gnome-config --modversion print | sed -e "s/gnome-print-//"`
+ if test "$vers" = "0.20"; then
AC_MSG_RESULT(found)
else
- AC_MSG_ERROR(You need at least GNOME print 0.13)
+ AC_MSG_ERROR(Please make sure you are using the released version of gnome-print-0.20. Please note that CVS HEAD versions will not work.)
fi
else
- AC_MSG_ERROR(Did not find GnomePrint installed)
+ AC_MSG_ERROR(Did not find GnomePrint installed. Please make sure you are using the released version of gnome-print-0.20. Please note that CVS HEAD versions will not work.)
fi
GNOME_PRINT_LIBS=`gnome-config --libs print`
GNOME_PRINT_CFLAGS=`gnome-config --cflags print`