aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2003-08-02 05:09:39 +0800
committerMichael Zucci <zucchi@src.gnome.org>2003-08-02 05:09:39 +0800
commit7f25447c68cea69317096e10fb3f779ea52635da (patch)
tree9e109526e99ac28c69dd4a0421bdb6b0da679b23 /configure.in
parentd40db13c85f289b4e611ee20ee00aef780e7ab3d (diff)
downloadgsoc2013-evolution-7f25447c68cea69317096e10fb3f779ea52635da.tar
gsoc2013-evolution-7f25447c68cea69317096e10fb3f779ea52635da.tar.gz
gsoc2013-evolution-7f25447c68cea69317096e10fb3f779ea52635da.tar.bz2
gsoc2013-evolution-7f25447c68cea69317096e10fb3f779ea52635da.tar.lz
gsoc2013-evolution-7f25447c68cea69317096e10fb3f779ea52635da.tar.xz
gsoc2013-evolution-7f25447c68cea69317096e10fb3f779ea52635da.tar.zst
gsoc2013-evolution-7f25447c68cea69317096e10fb3f779ea52635da.zip
Add option for '--enable-imapp', for 'new' imap code.
2003-08-01 Not Zed <NotZed@Ximian.com> * configure.in: Add option for '--enable-imapp', for 'new' imap code. svn path=/trunk/; revision=22063
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9a4ee07411..a960640777 100644
--- a/configure.in
+++ b/configure.in
@@ -445,6 +445,19 @@ else
fi
AM_CONDITIONAL(ENABLE_NNTP, test x$enable_nntp = xyes)
+dnl **************************************************
+dnl New IMAP code support.
+dnl **************************************************
+AC_ARG_ENABLE(imapp,
+[ --enable-imapp=[no/yes] Attempt to compile alternative, incomplete, very unsupported IMAPv4r1 code],,enable_imapp=no)
+if test "x$enable_imapp" = "xyes"; then
+ AC_DEFINE(ENABLE_IMAPP,1,[Really don't try this at home])
+ msg_imapp=yes
+else
+ msg_imapp=no
+fi
+AM_CONDITIONAL(ENABLE_IMAPP, test x$enable_imapp = xyes)
+
dnl **************************************************
dnl * Posix thread support
@@ -1317,6 +1330,7 @@ art/Makefile
camel/Makefile
camel/providers/Makefile
camel/providers/imap/Makefile
+camel/providers/imapp/Makefile
camel/providers/local/Makefile
camel/providers/nntp/Makefile
camel/providers/pop3/Makefile