aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSarfraaz Ahmed <asarfraaz@novell.com>2005-06-14 14:57:01 +0800
committerAhmed Sarfraaz <sarfraaz@src.gnome.org>2005-06-14 14:57:01 +0800
commit78f04d362464b38903d5e972966d3459be979ad9 (patch)
treea5bbe02920036a71b635686fc84836a2c619ad94 /configure.in
parentd12d5fd082bd480bd9b635dbdae72d439730273a (diff)
downloadgsoc2013-evolution-78f04d362464b38903d5e972966d3459be979ad9.tar
gsoc2013-evolution-78f04d362464b38903d5e972966d3459be979ad9.tar.gz
gsoc2013-evolution-78f04d362464b38903d5e972966d3459be979ad9.tar.bz2
gsoc2013-evolution-78f04d362464b38903d5e972966d3459be979ad9.tar.lz
gsoc2013-evolution-78f04d362464b38903d5e972966d3459be979ad9.tar.xz
gsoc2013-evolution-78f04d362464b38903d5e972966d3459be979ad9.tar.zst
gsoc2013-evolution-78f04d362464b38903d5e972966d3459be979ad9.zip
Add a configure option --enable-exchange to build Exchange plugins. Also
2005-06-14 Sarfraaz Ahmed <asarfraaz@novell.com> * configure.in : Add a configure option --enable-exchange to build Exchange plugins. Also changed the Exchange plugin name to exchange-operations. svn path=/trunk/; revision=29499
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4b9f43b399..9bb06f91f9 100644
--- a/configure.in
+++ b/configure.in
@@ -938,6 +938,18 @@ AC_SUBST(MANUAL_NSPR_LIBS)
AC_SUBST(MANUAL_NSS_CFLAGS)
AC_SUBST(MANUAL_NSS_LIBS)
+dnl **************************************************
+dnl Exchange support.
+dnl **************************************************
+AC_ARG_ENABLE(exchange,
+[ --enable-exchange=[no/yes] Build Exchange plugins],enable_exchange="$enableval",enable_exchange=no)
+if test "x$enable_exchange" = "xyes"; then
+ msg_exchange=yes
+else
+ msg_exchange=no
+fi
+AM_CONDITIONAL(ENABLE_EXCHANGE, test x$enable_exchange = xyes)
+
dnl ******************
dnl CDE dtappintegrate
dnl ******************
@@ -1138,9 +1150,13 @@ EVO_SET_COMPILE_FLAGS(CAMEL_GROUPWISE, camel-provider-$EDS_PACKAGE libedataserve
AC_SUBST(CAMEL_GROUPWISE_CFLAGS)
AC_SUBST(CAMEL_GROUPWISE_LIBS)
+if test "x$msg_exchange" != "xno"; then
EVO_SET_COMPILE_FLAGS(CAMEL_EXCHANGE, camel-provider-$EDS_PACKAGE libedataserver-$EDS_PACKAGE libexchange-storage-$EDS_PACKAGE >= $EDS_REQUIRED)
AC_SUBST(CAMEL_EXCHANGE_CFLAGS)
AC_SUBST(CAMEL_EXCHANGE_LIBS)
+EXCHANGE_PLUGIN="exchange-operations"
+EXCHANGE_PLUGIN_DIR='plugins/exchange-operations/Makefile'
+fi
if test "x$mozilla_nss" != "x"; then
EVO_SET_COMPILE_FLAGS(MOZILLA_NSS, $mozilla_nss)
@@ -1346,7 +1362,7 @@ AC_SUBST_FILE(EVO_PLUGIN_RULE)
AC_ARG_ENABLE(plugins, [ --enable-plugins=[no/base/all/experimental/list] Enable plugins.],enable_plugins="$enableval",enable_plugins=all)
dnl Add any new plugins here
-plugins_base="calendar-file calendar-http calendar-weather itip-formatter plugin-manager exchange-account-setup default-source addressbook-file startup-wizard print-message mark-all-read groupwise-features"
+plugins_base="calendar-file calendar-http calendar-weather itip-formatter plugin-manager default-source addressbook-file startup-wizard print-message mark-all-read groupwise-features $EXCHANGE_PLUGIN"
plugins_standard="bbdb subject-thread save-attachments prefer-plain save-calendar select-one-source copy-tool mail-to-task mark-calendar-offline audio-inline mailing-list-actions new-mail-notify"
@@ -1616,7 +1632,7 @@ plugins/folder-unsubscribe/Makefile
plugins/mailing-list-actions/Makefile
plugins/itip-formatter/Makefile
plugins/backup-restore/Makefile
-plugins/exchange-account-setup/Makefile
+plugins/exchange-operations/Makefile
plugins/default-source/Makefile
plugins/addressbook-file/Makefile
plugins/startup-wizard/Makefile