aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-11-26 13:46:33 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-11-26 13:46:33 +0800
commit9bedc8793f82e992f2ffb8d505af55f5478a89e3 (patch)
tree7097cb3b66969bd1678a50c9819a0e4075764cc2 /configure.in
parent18c08853768cc4cae9125aaf185268b90a0f23cf (diff)
downloadgsoc2013-evolution-9bedc8793f82e992f2ffb8d505af55f5478a89e3.tar
gsoc2013-evolution-9bedc8793f82e992f2ffb8d505af55f5478a89e3.tar.gz
gsoc2013-evolution-9bedc8793f82e992f2ffb8d505af55f5478a89e3.tar.bz2
gsoc2013-evolution-9bedc8793f82e992f2ffb8d505af55f5478a89e3.tar.lz
gsoc2013-evolution-9bedc8793f82e992f2ffb8d505af55f5478a89e3.tar.xz
gsoc2013-evolution-9bedc8793f82e992f2ffb8d505af55f5478a89e3.tar.zst
gsoc2013-evolution-9bedc8793f82e992f2ffb8d505af55f5478a89e3.zip
Drop the IPv6 and getaddrinfo checks, unused here in Evolution. (It's used
2005-11-26 Tor Lillqvist <tml@novell.com> * configure.in: Drop the IPv6 and getaddrinfo checks, unused here in Evolution. (It's used in e-d-s, though.) svn path=/trunk/; revision=30685
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in64
1 files changed, 1 insertions, 63 deletions
diff --git a/configure.in b/configure.in
index bc8e448854..f6e3212a3b 100644
--- a/configure.in
+++ b/configure.in
@@ -400,67 +400,6 @@ AC_SUBST(A11Y_CFLAGS)
AC_SUBST(A11Y_LIBS)
dnl **************************************************
-dnl * IPv6 support and getaddrinfo calls
-dnl **************************************************
-AC_CACHE_CHECK([if system supports getaddrinfo and getnameinfo], have_addrinfo,
-[
- AC_TRY_COMPILE([
- #include "confdefs.h"
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <netdb.h>
-
- ],[
- struct addrinfo hints, *res;
- struct sockaddr_in6 sin6;
- int af = AF_INET6;
- char host[NI_MAXHOST];
- char serv[NI_MAXSERV];
-
- getaddrinfo("www.ximian.com", 0, &hints, &res);
- freeaddrinfo(res);
- getnameinfo((struct sockaddr *)&sin6, sizeof(sin6), host, sizeof(host), serv, sizeof(serv), 0);
- ],[
- have_addrinfo=yes
- ],[
- have_addrinfo=no
- ])
-])
-
-if test x"$have_addrinfo" = "xno" ; then
- AC_DEFINE(NEED_ADDRINFO,1,[Enable getaddrinfo emulation])
- if test x"$enable_ipv6" = "xyes" ; then
- AC_ERROR(system doesn't support necessary interfaces for ipv6 support)
- fi
- msg_ipv6=no
-else
- AC_ARG_ENABLE(ipv6, [ --enable-ipv6=[no/yes] Enable support for resolving IPv6 addresses.],,enable_ipv6=yes)
- if test x"$enable_ipv6" = "xyes"; then
- msg_ipv6=yes
- AC_DEFINE(ENABLE_IPv6,1,[Enable IPv6 support])
- AC_TRY_COMPILE([
- #include "confdefs.h"
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <netdb.h>
-
- ],[
- struct addrinfo hints;
-
- hints.ai_flags = AI_ADDRCONFIG;
- ],[
- AC_DEFINE(HAVE_AI_ADDRCONFIG,1,[Define if the system defines the AI_ADDRCONFIG flag for getaddrinfo])
- ])
- else
- msg_ipv6=no
- fi
-fi
-
-AM_CONDITIONAL(ENABLE_IPv6, test "x$enable_ipv6" = "xyes")
-
-dnl **************************************************
dnl LDAP support.
dnl **************************************************
if test "$os_win32" != yes; then
@@ -486,7 +425,7 @@ AC_SUBST(LDAP_CFLAGS)
AC_SUBST(LDAP_LIBS)
AC_DEFINE(HAVE_LDAP,1,[Define if you have LDAP support])
AM_CONDITIONAL(ENABLE_LDAP, true)
-msg_exchange="yes"
+msg_ldap="yes"
fi # Win32
dnl **************************************************
@@ -1762,7 +1701,6 @@ echo "\
Kerberos 4/5: $msg_krb4/$msg_krb5
SSL support: $msg_ssl
SMIME support: $msg_smime
- IPv6 support: $msg_ipv6
Plugins: $msg_plugins
Gtk-doc: $enable_gtk_doc
DBus API version $DBUS_VERSION"