aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFrédéric Crozat <fcrozat@src.gnome.org>2004-08-14 00:09:31 +0800
committerFrédéric Crozat <fcrozat@src.gnome.org>2004-08-14 00:09:31 +0800
commit2881a782117bd8a3a6b4616dc9d9546bb1df5bb2 (patch)
tree8f6ceec0c3ad5bb763e4791fd4a1a2a47ebb9ee5 /configure.in
parent12b2f4da489be9d4788b16c28b5bb4b2214a8b89 (diff)
downloadgsoc2013-evolution-2881a782117bd8a3a6b4616dc9d9546bb1df5bb2.tar
gsoc2013-evolution-2881a782117bd8a3a6b4616dc9d9546bb1df5bb2.tar.gz
gsoc2013-evolution-2881a782117bd8a3a6b4616dc9d9546bb1df5bb2.tar.bz2
gsoc2013-evolution-2881a782117bd8a3a6b4616dc9d9546bb1df5bb2.tar.lz
gsoc2013-evolution-2881a782117bd8a3a6b4616dc9d9546bb1df5bb2.tar.xz
gsoc2013-evolution-2881a782117bd8a3a6b4616dc9d9546bb1df5bb2.tar.zst
gsoc2013-evolution-2881a782117bd8a3a6b4616dc9d9546bb1df5bb2.zip
Add option to specify location of kerberos 4/5 libraries and headers
* configure.in: Add option to specify location of kerberos 4/5 libraries and headers directories. Needed for 64bits support. svn path=/trunk/; revision=26917
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 34 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index f00b33d443..de21be61d4 100644
--- a/configure.in
+++ b/configure.in
@@ -528,8 +528,13 @@ AC_SUBST(GNOME_PILOT_LIBS)
dnl ********
dnl Kerberos
dnl ********
-AC_ARG_WITH(krb5, [ --with-krb5=PREFIX Location of Kerberos 5 libs/includes], with_krb5="$withval", with_krb5="no")
-AC_ARG_WITH(krb4, [ --with-krb4=PREFIX Location of Kerberos 4 libs/includes], with_krb4="$withval", with_krb4="no")
+AC_ARG_WITH(krb5, [ --with-krb5=DIR Location of Kerberos 5 install dir], with_krb5="$withval", with_krb5="no")
+AC_ARG_WITH(krb5-libs, [ --with-krb5-libs=DIR Location of Kerberos 5 libraries], with_krb5_libs="$withval", with_krb5_libs="$with_krb5/lib")
+AC_ARG_WITH(krb5-includes, [ --with-krb5-includes=DIR Location of Kerberos 5 headers], with_krb5_includes="$withval", with_krb5_includes="")
+AC_ARG_WITH(krb4, [ --with-krb4=DIR Location of Kerberos 4 install dir], with_krb4="$withval", with_krb4="no")
+AC_ARG_WITH(krb4-libs, [ --with-krb4-libs=DIR Location of Kerberos 4 libraries], with_krb4_libs="$withval", with_krb4_libs="$with_krb4/lib")
+AC_ARG_WITH(krb4-includes, [ --with-krb4-includes=DIR Location of Kerberos 4 headers], with_krb4_includes="$withval", with_krb4_includes="")
+
msg_krb5="no"
if test "x${with_krb5}" != "xno"; then
@@ -539,10 +544,10 @@ if test "x${with_krb5}" != "xno"; then
heimlibs="-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi"
AC_CACHE_CHECK([for Kerberos 5], ac_cv_lib_kerberos5,
[
- LDFLAGS="$LDFLAGS -L$with_krb5/lib $mitlibs"
+ LDFLAGS="$LDFLAGS -L$with_krb5_libs $mitlibs"
AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$mitlibs",
[
- LDFLAGS="$LDFLAGS_save -L$with_krb5/lib $heimlibs"
+ LDFLAGS="$LDFLAGS_save -L$with_krb5_libs $heimlibs"
AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$heimlibs", ac_cv_lib_kerberos5="no")
])
LDFLAGS="$LDFLAGS_save"
@@ -551,14 +556,22 @@ if test "x${with_krb5}" != "xno"; then
AC_DEFINE(HAVE_KRB5,1,[Define if you have Krb5])
if test "$ac_cv_lib_kerberos5" = "$mitlibs"; then
AC_DEFINE(HAVE_MIT_KRB5,1,[Define if you have MIT Krb5])
- KRB5_CFLAGS="-I$with_krb5/include"
+ if test -z "$with_krb5_includes"; then
+ KRB5_CFLAGS="-I$with_krb5/include"
+ else
+ KRB5_CFLAGS="-I$with_krb5_includes"
+ fi
msg_krb5="yes (MIT)"
else
AC_DEFINE(HAVE_HEIMDAL_KRB5,1,[Define if you have Heimdal])
- KRB5_CFLAGS="-I$with_krb5/include/heimdal"
+ if test -z "$with_krb5_includes"; then
+ KRB5_CFLAGS="-I$with_krb5/include/heimdal"
+ else
+ KRB5_CFLAGS="-I$with_krb5_includes"
+ fi
msg_krb5="yes (Heimdal)"
fi
- KRB5_LDFLAGS="-L$with_krb5/lib $ac_cv_lib_kerberos5"
+ KRB5_LDFLAGS="-L$with_krb5_libs $ac_cv_lib_kerberos5"
fi
else
AC_MSG_CHECKING(for Kerberos 5)
@@ -577,17 +590,17 @@ if test "x${with_krb4}" != "xno"; then
mitcompatlibs="-lkrb4 -ldes425 -lkrb5 -lk5crypto -lcom_err"
# Look for MIT krb5 compat krb4
- LDFLAGS="$LDFLAGS -L$with_krb4/lib $mitcompatlibs"
+ LDFLAGS="$LDFLAGS -L$with_krb4_libs $mitcompatlibs"
AC_TRY_LINK_FUNC(krb_mk_req, ac_cv_lib_kerberos4="$mitcompatlibs")
if test "$ac_cv_lib_kerberos4" = "no"; then
# Look for KTH krb4
- LDFLAGS="$LDFLAGS_save -L$with_krb4/lib -lkrb -lcrypto -lcom_err -lroken"
+ LDFLAGS="$LDFLAGS_save -L$with_krb4_libs -lkrb -lcrypto -lcom_err -lroken"
AC_TRY_LINK_FUNC(krb_mk_req, ac_cv_lib_kerberos4="-lkrb -lcrypto -lcom_err -lroken")
fi
if test "$ac_cv_lib_kerberos4" = "no"; then
# Look for old MIT krb4
- LDFLAGS="$LDFLAGS_save -L$with_krb4/lib -lkrb"
+ LDFLAGS="$LDFLAGS_save -L$with_krb4_libs -lkrb"
AC_TRY_LINK_FUNC(krb_mk_req, ac_cv_lib_kerberos4="-lkrb",
[
LDFLAGS="$LDFLAGS -ldes"
@@ -599,13 +612,18 @@ if test "x${with_krb4}" != "xno"; then
if test "$ac_cv_lib_kerberos4" != "no"; then
AC_DEFINE(HAVE_KRB4,1,[Define if you have Krb4])
msg_krb4="yes"
- if test -f "$with_krb4/include/krb.h" -o -f "$with_krb4/include/port-sockets.h"; then
- KRB4_CFLAGS="-I$with_krb4/include"
- fi
- if test -d "$with_krb4/include/kerberosIV"; then
- KRB4_CFLAGS="$KRB4_CFLAGS -I$with_krb4/include/kerberosIV"
+
+ if test -z "$with_krb4_includes"; then
+ if test -f "$with_krb4/include/krb.h" -o -f "$with_krb4/include/port-sockets.h"; then
+ KRB4_CFLAGS="-I$with_krb4/include"
+ fi
+ if test -d "$with_krb4/include/kerberosIV"; then
+ KRB4_CFLAGS="$KRB4_CFLAGS -I$with_krb4/include/kerberosIV"
+ fi
+ else
+ KRB4_CFLAGS="-I$with_krb4_includes"
fi
- KRB4_LDFLAGS="-L$with_krb4/lib $ac_cv_lib_kerberos4"
+ KRB4_LDFLAGS="-L$with_krb4_libs $ac_cv_lib_kerberos4"
CFLAGS_save="$CFLAGS"
CFLAGS="$CFLAGS $KRB4_CFLAGS"