aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSuman Manjunath <msuman@src.gnome.org>2008-12-10 11:38:51 +0800
committerSuman Manjunath <msuman@src.gnome.org>2008-12-10 11:38:51 +0800
commit415b951b22cd467afadf1866c53ef5c1caa5eacb (patch)
treeddc360b982132ef73a2699e8440d99a54a7a27f0 /configure.in
parente21153cdc86e029a16501cb8686f99f93a15555f (diff)
downloadgsoc2013-evolution-415b951b22cd467afadf1866c53ef5c1caa5eacb.tar
gsoc2013-evolution-415b951b22cd467afadf1866c53ef5c1caa5eacb.tar.gz
gsoc2013-evolution-415b951b22cd467afadf1866c53ef5c1caa5eacb.tar.bz2
gsoc2013-evolution-415b951b22cd467afadf1866c53ef5c1caa5eacb.tar.lz
gsoc2013-evolution-415b951b22cd467afadf1866c53ef5c1caa5eacb.tar.xz
gsoc2013-evolution-415b951b22cd467afadf1866c53ef5c1caa5eacb.tar.zst
gsoc2013-evolution-415b951b22cd467afadf1866c53ef5c1caa5eacb.zip
Make the libgweather dependency optional, build the weather calendar setup plugin by default and provide an option to disable it.
svn path=/trunk/; revision=36860
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3281a137f9..c1c23298de 100644
--- a/configure.in
+++ b/configure.in
@@ -43,6 +43,7 @@ m4_define([dbus_minimum_version], [1.0.0])
m4_define([hal_minimum_version], [0.5.4])
m4_define([libnotify_minimum_version], [0.3.0])
m4_define([gnome_pilot_minimum_version], [2.0.15])
+m4_define([gweather_minimum_version], [2.25.3])
# GNOME Documentation
GNOME_DOC_INIT
@@ -1206,6 +1207,25 @@ AC_SUBST(MANUAL_NSS_CFLAGS)
AC_SUBST(MANUAL_NSS_LIBS)
dnl **************************************************
+dnl Check if we should build the weather calendar plugin
+dnl **************************************************
+AC_MSG_CHECKING(if we should build the weather calendar plugin)
+AC_ARG_WITH([weather],
+ [AS_HELP_STRING([--with-weather], [Build the weather calendar setup plugin (default=yes)])],
+ [use_gweather=$withval],
+ [use_gweather=yes])
+AC_MSG_RESULT($use_gweather)
+
+if test $use_gweather = yes; then
+ PKG_CHECK_MODULES([LIBGWEATHER],
+ [gweather >= gweather_minimum_version],
+ [CALENDAR_WEATHER="calendar-weather"],
+ [AC_MSG_ERROR([The weather calendar setup plugin requires GWeather >= gweather_minimum_version. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin.])])
+else
+ CALENDAR_WEATHER=""
+fi
+
+dnl **************************************************
dnl Exchange support.
dnl **************************************************
AC_ARG_ENABLE([exchange],
@@ -1734,7 +1754,7 @@ AC_ARG_ENABLE([plugins],
[enable_plugins="$enableval"],[enable_plugins=all])
dnl Add any new plugins here
-plugins_base_always="calendar-file calendar-http calendar-weather itip-formatter plugin-manager default-source addressbook-file startup-wizard mark-all-read groupwise-features groupwise-account-setup mail-account-disable publish-calendar caldav imap-features google-account-setup webdav-account-setup"
+plugins_base_always="calendar-file calendar-http $CALENDAR_WEATHER itip-formatter plugin-manager default-source addressbook-file startup-wizard mark-all-read groupwise-features groupwise-account-setup mail-account-disable publish-calendar caldav imap-features google-account-setup webdav-account-setup"
plugins_base="$plugins_base_always $SA_JUNK_PLUGIN $BF_JUNK_PLUGIN $EXCHANGE_PLUGIN $MONO_PLUGIN "
all_plugins_base="$plugins_base_always sa-junk-plugin bogo-junk-plugin exchange-operations mono"