aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSarfraaz Ahmed <asarfraaz@novell.com>2005-08-25 21:58:33 +0800
committerAhmed Sarfraaz <sarfraaz@src.gnome.org>2005-08-25 21:58:33 +0800
commit4d70956356d1d7a6e8db3ebd226ccc5e5bc2d082 (patch)
treedff7c7c8f1fee587cf2783fc719fa087d49a6f28 /configure.in
parent15780717c786d27e31af9ea2ebed0f3d9f549b74 (diff)
downloadgsoc2013-evolution-4d70956356d1d7a6e8db3ebd226ccc5e5bc2d082.tar
gsoc2013-evolution-4d70956356d1d7a6e8db3ebd226ccc5e5bc2d082.tar.gz
gsoc2013-evolution-4d70956356d1d7a6e8db3ebd226ccc5e5bc2d082.tar.bz2
gsoc2013-evolution-4d70956356d1d7a6e8db3ebd226ccc5e5bc2d082.tar.lz
gsoc2013-evolution-4d70956356d1d7a6e8db3ebd226ccc5e5bc2d082.tar.xz
gsoc2013-evolution-4d70956356d1d7a6e8db3ebd226ccc5e5bc2d082.tar.zst
gsoc2013-evolution-4d70956356d1d7a6e8db3ebd226ccc5e5bc2d082.zip
Enable building of exchange plugins by default.
2005-08-24 Sarfraaz Ahmed <asarfraaz@novell.com> * configure.in : Enable building of exchange plugins by default. svn path=/trunk/; revision=30249
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 17 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index ab54ceab09..18615875ed 100644
--- a/configure.in
+++ b/configure.in
@@ -985,9 +985,10 @@ dnl **************************************************
dnl Exchange support.
dnl **************************************************
AC_ARG_ENABLE(exchange,
-[ --enable-exchange=[no/yes] Build Exchange plugins],enable_exchange="$enableval",enable_exchange=no)
+[ --enable-exchange=[no/yes] Build Exchange plugins],enable_exchange="$enableval",enable_exchange=yes)
if test "x$enable_exchange" = "xyes"; then
msg_exchange=yes
+ EXCHANGE_PLUGIN="exchange-operations"
else
msg_exchange=no
fi
@@ -1193,14 +1194,6 @@ EVO_SET_COMPILE_FLAGS(CAMEL_GROUPWISE, camel-provider-$EDS_PACKAGE libedataserve
AC_SUBST(CAMEL_GROUPWISE_CFLAGS)
AC_SUBST(CAMEL_GROUPWISE_LIBS)
-if test "x$msg_exchange" != "xno"; then
-EVO_SET_COMPILE_FLAGS(CAMEL_EXCHANGE, camel-provider-$EDS_PACKAGE libedataserver-$EDS_PACKAGE libexchange-storage-$EDS_PACKAGE >= $EDS_REQUIRED)
-AC_SUBST(CAMEL_EXCHANGE_CFLAGS)
-AC_SUBST(CAMEL_EXCHANGE_LIBS)
-EXCHANGE_PLUGIN="exchange-operations"
-EXCHANGE_PLUGIN_DIR='plugins/exchange-operations/Makefile'
-fi
-
if test "x$mozilla_nss" != "x"; then
EVO_SET_COMPILE_FLAGS(MOZILLA_NSS, $mozilla_nss)
MOZILLA_L_DIR=`pkg-config --libs-only-L $mozilla_nss`
@@ -1502,6 +1495,21 @@ if echo ${plugins_enabled} | grep -q "new-mail-notify" ; then
fi
fi
+if echo ${plugins_enabled} | grep -q "exchange-operations" ; then
+ if ${PKG_CONFIG} --exists libexchange-storage-$EDS_PACKAGE ; then
+ dnl **************************************************
+ dnl * Exchange Operations plugin
+ dnl **************************************************
+ EVO_SET_COMPILE_FLAGS(CAMEL_EXCHANGE, camel-provider-$EDS_PACKAGE libedataserver-$EDS_PACKAGE libexchange-storage-$EDS_PACKAGE >= $EDS_REQUIRED)
+ AC_SUBST(CAMEL_EXCHANGE_CFLAGS)
+ AC_SUBST(CAMEL_EXCHANGE_LIBS)
+ else
+ plugins_enabled=`echo $plugins_enabled | sed -e "s/exchange-operations//g"`
+ echo "warning: libevolution-exchange-$EDS_PACKAGE was not found, Exchange Operations plugin will not be built."
+ fi
+fi
+
+
##################################################
# Check for gtk-doc.
##################################################