aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-06-19 01:47:40 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-06-19 01:47:40 +0800
commit3998d8c399a8f1477a83c3fcc5248fcb3d9d6fa8 (patch)
tree122598e56030a89bbf4edb13b548648ffee94c9d /configure.in
parent2f68a1a5bfe3b652d3125b4ed07b07b289a23b96 (diff)
downloadgsoc2013-evolution-3998d8c399a8f1477a83c3fcc5248fcb3d9d6fa8.tar
gsoc2013-evolution-3998d8c399a8f1477a83c3fcc5248fcb3d9d6fa8.tar.gz
gsoc2013-evolution-3998d8c399a8f1477a83c3fcc5248fcb3d9d6fa8.tar.bz2
gsoc2013-evolution-3998d8c399a8f1477a83c3fcc5248fcb3d9d6fa8.tar.lz
gsoc2013-evolution-3998d8c399a8f1477a83c3fcc5248fcb3d9d6fa8.tar.xz
gsoc2013-evolution-3998d8c399a8f1477a83c3fcc5248fcb3d9d6fa8.tar.zst
gsoc2013-evolution-3998d8c399a8f1477a83c3fcc5248fcb3d9d6fa8.zip
New autoconf variable. On Unix it is identical to privlibdir, on Win32
2005-06-18 Tor Lillqvist <tml@novell.com> * configure.in (privsolibdir): New autoconf variable. On Unix it is identical to privlibdir, on Win32 identical to libdir. There is no RPATH mechanism in Win32 DLLs or EXEs. The intention is that Evolution's private shared libraries will be marked in the Makefile.am files as privsolib_LTLIBRARIES. They will thus on Windows get installed in libdir. The DLLs will actually get installed in bindir, thanks to libtool magic. It will thus suffice to have bindir in PATH. This also means that we can use gnome_win32_get_prefixes() in libeutil to find out the installation location on the end-user machine based on the location of the DLL. gnome_win32_get_prefixes() assumes the DLL is in a "bin" subfolder of the end-user installation prefix. svn path=/trunk/; revision=29544
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6f1c15bf74..208b73a287 100644
--- a/configure.in
+++ b/configure.in
@@ -1405,6 +1405,18 @@ dnl --- etc)
privlibdir='${libdir}'/evolution/$BASE_VERSION
AC_SUBST(privlibdir)
+if test "$os_win32" = yes; then
+ # On Win32 there is no "rpath" mechanism. We install the private
+ # shared libraries in $libdir, meaning the DLLs will actually be in
+ # $bindir. This means just having $bindir in PATH will be enough. This
+ # also means gnome_win32_get_prefixes() will be able to deduce the
+ # installation folder correctly.
+ privsolibdir=$libdir
+else
+ privsolibdir=$privlibdir
+fi
+AC_SUBST(privsolibdir)
+
privlibexecdir='${libexecdir}'/evolution/$BASE_VERSION
AC_SUBST(privlibexecdir)