aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-11-07 05:24:29 +0800
committerDan Winship <danw@src.gnome.org>2000-11-07 05:24:29 +0800
commitf521595158abfc1e5aa63aae3a721290289eaa8f (patch)
tree9ca1d6bf69acd8a793d3a96aa7841b947d762f84 /configure.in
parentbbe8c73db98b02f3e12b12ddd32aca4968607dec (diff)
downloadgsoc2013-evolution-f521595158abfc1e5aa63aae3a721290289eaa8f.tar
gsoc2013-evolution-f521595158abfc1e5aa63aae3a721290289eaa8f.tar.gz
gsoc2013-evolution-f521595158abfc1e5aa63aae3a721290289eaa8f.tar.bz2
gsoc2013-evolution-f521595158abfc1e5aa63aae3a721290289eaa8f.tar.lz
gsoc2013-evolution-f521595158abfc1e5aa63aae3a721290289eaa8f.tar.xz
gsoc2013-evolution-f521595158abfc1e5aa63aae3a721290289eaa8f.tar.zst
gsoc2013-evolution-f521595158abfc1e5aa63aae3a721290289eaa8f.zip
${prefix} doesn't get defaulted until the end of configure, so check if
* configure.in (GTKHTML_LIBS): ${prefix} doesn't get defaulted until the end of configure, so check if it's "NONE" and use ${ac_default_prefix} if so. svn path=/trunk/; revision=6426
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5ad702ca3b..0a0418b3ca 100644
--- a/configure.in
+++ b/configure.in
@@ -351,13 +351,18 @@ GTKHTML_LIBS="`gnome-config --libs gtkhtml`"
AC_SUBST(GTKHTML_CFLAGS)
AC_SUBST(GTKHTML_LIBS)
-AC_MSG_CHECKING(for HTMLEditor.idl in `gnome-config --datadir`/gtkhtml or ${prefix}/share/gtkhtml)
+if test x${prefix} = xNONE; then
+ html_prefix=$ac_default_prefix
+else
+ html_prefix=$prefix
+fi
+AC_MSG_CHECKING(for HTMLEditor.idl in `gnome-config --datadir`/gtkhtml or ${html_prefix}/share/gtkhtml)
if test -f `gnome-config --datadir`/gtkhtml/HTMLEditor.idl; then
GTK_HTML_EDITOR_IDL=`gnome-config --datadir`/gtkhtml/HTMLEditor.idl
AC_MSG_RESULT(found)
else
- if test -f ${prefix}/share/gtkhtml/HTMLEditor.idl; then
- GTK_HTML_EDITOR_IDL=${prefix}/share/gtkhtml/HTMLEditor.idl
+ if test -f ${html_prefix}/share/gtkhtml/HTMLEditor.idl; then
+ GTK_HTML_EDITOR_IDL=${html_prefix}/share/gtkhtml/HTMLEditor.idl
AC_MSG_RESULT(found)
else
AC_MSG_ERROR(HTMLEditor.idl is required to compile Evolution composer, it's included in GtkHTML