aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2001-02-02 11:09:11 +0800
committerChris Toshok <toshok@src.gnome.org>2001-02-02 11:09:11 +0800
commit0c6b184aaa8e1ab1c0798c76ba809cffec3f4746 (patch)
treea3a54293b5bf6dd7f494c6c6d6bd7aafc10ae2cf /configure.in
parentc051d7fa5200dd51fe23422ce2a5b87c8bba14f0 (diff)
downloadgsoc2013-evolution-0c6b184aaa8e1ab1c0798c76ba809cffec3f4746.tar
gsoc2013-evolution-0c6b184aaa8e1ab1c0798c76ba809cffec3f4746.tar.gz
gsoc2013-evolution-0c6b184aaa8e1ab1c0798c76ba809cffec3f4746.tar.bz2
gsoc2013-evolution-0c6b184aaa8e1ab1c0798c76ba809cffec3f4746.tar.lz
gsoc2013-evolution-0c6b184aaa8e1ab1c0798c76ba809cffec3f4746.tar.xz
gsoc2013-evolution-0c6b184aaa8e1ab1c0798c76ba809cffec3f4746.tar.zst
gsoc2013-evolution-0c6b184aaa8e1ab1c0798c76ba809cffec3f4746.zip
allow --enable/disable-ldap.
2001-02-01 Chris Toshok <toshok@ximian.com> * configure.in: allow --enable/disable-ldap. svn path=/trunk/; revision=7943
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index f6a580fcc8..7c742734a3 100644
--- a/configure.in
+++ b/configure.in
@@ -147,16 +147,19 @@ AC_CHECK_HEADERS(db1/db.h)
dnl **************************************************
dnl * ldap related stuff.
dnl **************************************************
-AC_CHECK_LIB(lber, ber_get_tag, LDAP_LIBS="-llber")
-if test x$ac_cv_lib_lber_ber_get_tag = xyes; then
-AC_CHECK_LIB(ldap, ldap_open, LDAP_LIBS="-lldap $LDAP_LIBS", ,-llber)
+AC_ARG_ENABLE(ldap,
+[ --enable-ldap=[no/yes] Enable LDAP support in evolution],,enable_ldap=no)
+if test x$enable_ldap = xyes; then
+ AC_CHECK_LIB(lber, ber_get_tag, LDAP_LIBS="-llber")
+ if test x$ac_cv_lib_lber_ber_get_tag = xyes; then
+ AC_CHECK_LIB(ldap, ldap_open, LDAP_LIBS="-lldap $LDAP_LIBS", ,-llber)
+ fi
fi
if test x$ac_cv_lib_ldap_ldap_open = xyes; then
AC_DEFINE(HAVE_LDAP)
AC_SUBST(LDAP_LIBS)
msg_ldap=Yes
else
- AC_MSG_WARN(no ldap support present)
msg_ldap=No
fi
AM_CONDITIONAL(ENABLE_LDAP, test x$ac_cv_lib_ldap_ldap_open = xyes)