aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2013-11-29 19:59:09 +0800
committerMilan Crha <mcrha@redhat.com>2013-11-29 19:59:09 +0800
commite607ae83d43972943b138915fb86b244498e8845 (patch)
treec080cef975bfa4c6724a62636f426f1099b4cdae /configure.ac
parentc12a958aba0bac2b665cc8a5a3cae2f10d16dd71 (diff)
downloadgsoc2013-evolution-e607ae83d43972943b138915fb86b244498e8845.tar
gsoc2013-evolution-e607ae83d43972943b138915fb86b244498e8845.tar.gz
gsoc2013-evolution-e607ae83d43972943b138915fb86b244498e8845.tar.bz2
gsoc2013-evolution-e607ae83d43972943b138915fb86b244498e8845.tar.lz
gsoc2013-evolution-e607ae83d43972943b138915fb86b244498e8845.tar.xz
gsoc2013-evolution-e607ae83d43972943b138915fb86b244498e8845.tar.zst
gsoc2013-evolution-e607ae83d43972943b138915fb86b244498e8845.zip
Bug #329616 - Spell checking for Event/Task/Memo editors
This is based on the work of Jan-Michael Brummer from bug #705338, just a little extended to be reusable across whole evolution.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0f5c8f7fc..ae7fb24b2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1087,6 +1087,30 @@ CFLAGS=$save_cflags
LIBS=$save_libs
AC_MSG_RESULT([$ac_cv_have_iuth])
+dnl ****************************
+dnl Check for gtkspell
+dnl ****************************
+AC_ARG_ENABLE([gtkspell],
+ [AS_HELP_STRING([--enable-gtkspell],
+ [Enable gtkspell @<:@default=yes@:>@])],
+ [enable_gtkspell="$enableval"], [enable_gtkspell="yes"])
+
+if test "x$enable_gtkspell" = "xyes"; then
+ PKG_CHECK_MODULES(
+ [GTKSPELL],
+ [gtkspell3-3.0],,
+ [AC_MSG_ERROR([
+
+ gtkspell3-3.0 not found
+
+ If you want to disable the gtkspell feature,
+ please append --disable-gtkspell to configure.
+
+ ])])
+
+ AC_DEFINE(WITH_GTKSPELL, 1, [When defined spell checking is enabled])
+fi
+
dnl *******************
dnl Special directories
dnl *******************