aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-12-10 21:09:59 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-12-13 03:33:43 +0800
commitd09d8de870b6697c8a8b262e7e077b871a69b315 (patch)
tree3b718882e7a0bb0a996daf2967a033d91714c9b5 /configure.ac
parentb61331ed03ac1c7a9b8614e25510040b9c60ae02 (diff)
downloadgsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.gz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.bz2
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.lz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.xz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.zst
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.zip
Consolidate base utility libraries into libeutil.
Evolution consists of entirely too many small utility libraries, which increases linking and loading time, places a burden on higher layers of the application (e.g. modules) which has to remember to link to all the small in-tree utility libraries, and makes it difficult to generate API documentation for these utility libraries in one Gtk-Doc module. Merge the following utility libraries under the umbrella of libeutil, and enforce a single-include policy on libeutil so we can reorganize the files as desired without disrupting its pseudo-public API. libemail-utils/libemail-utils.la libevolution-utils/libevolution-utils.la filter/libfilter.la widgets/e-timezone-dialog/libetimezonedialog.la widgets/menus/libmenus.la widgets/misc/libemiscwidgets.la widgets/table/libetable.la widgets/text/libetext.la This also merges libedataserverui from the Evolution-Data-Server module, since Evolution is its only consumer nowadays, and I'd like to make some improvements to those APIs without concern for backward-compatibility. And finally, start a Gtk-Doc module for libeutil. It's going to be a project just getting all the symbols _listed_ much less _documented_. But the skeletal structure is in place and I'm off to a good start.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 7f5f844756..d2d5d5bf10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -303,7 +303,6 @@ PKG_CHECK_MODULES([EVOLUTION_DATA_SERVER],
libebook-1.2 >= eds_minimum_version
libecal-1.2 >= eds_minimum_version
libedataserver-1.2 >= eds_minimum_version
- libedataserverui-3.0 >= eds_minimum_version
libebackend-1.2 >= eds_minimum_version])
AC_SUBST(EVOLUTION_DATA_SERVER_CFLAGS)
AC_SUBST(EVOLUTION_DATA_SERVER_LIBS)
@@ -1565,7 +1564,6 @@ AC_SUBST(EVOLUTION_DIR)
AC_CONFIG_FILES([ po/Makefile.in
Makefile
-a11y/Makefile
addressbook/Makefile
addressbook/gui/Makefile
addressbook/gui/contact-editor/Makefile
@@ -1585,10 +1583,10 @@ data/evolution-settings.desktop.in
data/icons/Makefile
doc/Makefile
doc/reference/Makefile
-doc/reference/shell/Makefile
+doc/reference/libeshell/Makefile
+doc/reference/libeutil/Makefile
e-util/Makefile
em-format/Makefile
-filter/Makefile
help/Makefile
help/quickref/Makefile
help/quickref/C/Makefile
@@ -1604,10 +1602,6 @@ help/quickref/pl/Makefile
help/quickref/pt/Makefile
help/quickref/sv/Makefile
help/quickref/sq/Makefile
-libevolution-utils/Makefile
-libevolution-utils/libevolution-utils.pc
-libemail-utils/Makefile
-libemail-utils/libemail-utils.pc
libemail-engine/Makefile
libemail-engine/libemail-engine.pc
libgnomecanvas/Makefile
@@ -1620,12 +1614,6 @@ views/calendar/Makefile
views/mail/Makefile
views/tasks/Makefile
views/memos/Makefile
-widgets/Makefile
-widgets/e-timezone-dialog/Makefile
-widgets/menus/Makefile
-widgets/misc/Makefile
-widgets/text/Makefile
-widgets/table/Makefile
calendar/Makefile
calendar/alarm-notify/Makefile
calendar/importers/Makefile