aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-07-30 18:49:20 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-07-30 18:51:33 +0800
commit80d4fed16263cb7bf31ca219642b867e4e77f45a (patch)
treec578596fd9c4824cf10cbecb41f5ab337afc74ee /configure.ac
parent8995915a5eb1cf79274954f501f55889e8ee1369 (diff)
downloadgsoc2013-evolution-80d4fed16263cb7bf31ca219642b867e4e77f45a.tar
gsoc2013-evolution-80d4fed16263cb7bf31ca219642b867e4e77f45a.tar.gz
gsoc2013-evolution-80d4fed16263cb7bf31ca219642b867e4e77f45a.tar.bz2
gsoc2013-evolution-80d4fed16263cb7bf31ca219642b867e4e77f45a.tar.lz
gsoc2013-evolution-80d4fed16263cb7bf31ca219642b867e4e77f45a.tar.xz
gsoc2013-evolution-80d4fed16263cb7bf31ca219642b867e4e77f45a.tar.zst
gsoc2013-evolution-80d4fed16263cb7bf31ca219642b867e4e77f45a.zip
Bug 624500 - Missing EggSMClient linker flags in shell
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c793762b20..5a8542084a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1376,7 +1376,11 @@ AC_SUBST(DATASERVER_EXEC_VERSION)
dnl *****************
dnl EggSMClient Flags
dnl *****************
-EVO_SET_COMPILE_FLAGS(EGG_SMCLIENT, $GTK)
+if test "x$os_win32" = "xyes"; then
+ EVO_SET_COMPILE_FLAGS(EGG_SMCLIENT, $GTK)
+else
+ EVO_SET_COMPILE_FLAGS(EGG_SMCLIENT, $GTK,, -lSM -lICE)
+fi
AC_SUBST(EGG_SMCLIENT_CFLAGS)
AC_SUBST(EGG_SMCLIENT_LIBS)