aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@novell.com>2010-03-24 18:24:56 +0800
committerMichael Meeks <michael.meeks@novell.com>2010-03-26 03:53:12 +0800
commit342fa27bb78f177150e1deb7842f749637c91948 (patch)
tree8b93d57a751bcff12a40a69aeaa40e164e73b726 /configure.ac
parent7b953918ebc9e5dd6812dcb55a3bf272cfa8a530 (diff)
downloadgsoc2013-evolution-342fa27bb78f177150e1deb7842f749637c91948.tar
gsoc2013-evolution-342fa27bb78f177150e1deb7842f749637c91948.tar.gz
gsoc2013-evolution-342fa27bb78f177150e1deb7842f749637c91948.tar.bz2
gsoc2013-evolution-342fa27bb78f177150e1deb7842f749637c91948.tar.lz
gsoc2013-evolution-342fa27bb78f177150e1deb7842f749637c91948.tar.xz
gsoc2013-evolution-342fa27bb78f177150e1deb7842f749637c91948.tar.zst
gsoc2013-evolution-342fa27bb78f177150e1deb7842f749637c91948.zip
Add ConnMan support (words fail me ...)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 86ac1b4621..f634caf627 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1140,7 +1140,6 @@ if test "$enable_nm" = yes; then
AC_SUBST(HAVE_NM)
AC_SUBST(NM_CFLAGS)
fi
-
AM_CONDITIONAL([ENABLE_NETWORK_MANAGER], [test "$enable_nm" = yes])
dnl ******************************
@@ -1165,6 +1164,18 @@ fi
AM_CONDITIONAL([ENABLE_WINDOWS_SENS], [test "$enable_sens" = yes])
dnl ******************************
+dnl Enable ConnMan support ?
+dnl ******************************
+AC_ARG_ENABLE([connman],
+ [AS_HELP_STRING([--enable-connman],
+ [enable ConnMan support (default=no)])],
+ [enable_connman=$enableval],[enable_connman=no])
+if test "x$enable_nm$enable_connman" = "xyesyes"; then
+ AC_MSG_ERROR([It is not possible to enable both ConnMan and NetworkManager])
+fi
+AM_CONDITIONAL([ENABLE_CONNMAN], [test "$enable_connman" = yes])
+
+dnl ******************************
dnl Camel Flags
dnl ******************************
EVO_SET_COMPILE_FLAGS(CAMEL, camel-provider-1.2, $MANUAL_NSS_CFLAGS, $MOXILLA_NSS_CFLAGS)
@@ -1726,6 +1737,7 @@ modules/addressbook/Makefile
modules/calendar/Makefile
modules/mail/Makefile
modules/network-manager/Makefile
+modules/connman/Makefile
modules/plugin-lib/Makefile
modules/plugin-mono/Makefile
modules/plugin-python/Makefile