aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-12-04 22:58:48 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-12-04 23:06:03 +0800
commit2cbdd00f55f0598a3c7d060c1a973f5c3f6bd15e (patch)
treee2271f359f56265cdba8e6711beba3bae7a81909 /configure.ac
parent68ff4eff5678916a3886200f2ca2cd47324a00fb (diff)
downloadgsoc2013-evolution-2cbdd00f55f0598a3c7d060c1a973f5c3f6bd15e.tar
gsoc2013-evolution-2cbdd00f55f0598a3c7d060c1a973f5c3f6bd15e.tar.gz
gsoc2013-evolution-2cbdd00f55f0598a3c7d060c1a973f5c3f6bd15e.tar.bz2
gsoc2013-evolution-2cbdd00f55f0598a3c7d060c1a973f5c3f6bd15e.tar.lz
gsoc2013-evolution-2cbdd00f55f0598a3c7d060c1a973f5c3f6bd15e.tar.xz
gsoc2013-evolution-2cbdd00f55f0598a3c7d060c1a973f5c3f6bd15e.tar.zst
gsoc2013-evolution-2cbdd00f55f0598a3c7d060c1a973f5c3f6bd15e.zip
Remove --enable-strict configure option.
GLib/GTK+ uses different deprecation macros nowadays. The MIN_REQUIRED macros do a better job of catching deprecated symbol usage up to the minimum build requirement, and the MAX_ALLOWED macros catch symbol usage that violates our minimum build requirement. These newer deprecation macros are always enabled, so we don't need a special configure flag for them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 36e7e5d5d2..a3ae349cf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,29 +103,6 @@ dnl -Wstrict-aliasing=2
AM_CPPFLAGS="$WARNING_FLAGS -fno-strict-aliasing"
-dnl *******************************
-dnl Check for --enable-strict
-dnl *******************************
-AC_ARG_ENABLE([strict],
- [AS_HELP_STRING([--enable-strict],
- [enable strict building, like without deprecated symbols (default=auto); auto enables strict building only if .git subdirectory exists])],
- [enable_strict=$enableval], [enable_strict=auto])
-
-AC_MSG_CHECKING([if strict building is enabled])
-if test "x$enable_strict" = xauto; then
- dnl Be strict when compiling with .git subdirectory
- if test -d .git ; then
- enable_strict=yes
- else
- enable_strict=no
- fi
-fi
-AC_MSG_RESULT([$enable_strict])
-
-if test "x$enable_strict" = xyes; then
- AM_CPPFLAGS="$AM_CPPFLAGS -DG_DISABLE_DEPRECATED"
-fi
-
dnl Warn about API usage that violates our minimum requirements.
AM_CPPFLAGS="$AM_CPPFLAGS -DGLIB_VERSION_MAX_ALLOWED=glib_encoded_version"
AM_CPPFLAGS="$AM_CPPFLAGS -DGDK_VERSION_MAX_ALLOWED=gdk_encoded_version"
@@ -1625,5 +1602,4 @@ echo "
Highlight support: $msg_text_highlight
Plugins: $msg_plugins
User documentation: $with_help
- Strict building: $enable_strict
"