aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@novell.com>2010-03-24 18:24:56 +0800
committerMichael Meeks <michael.meeks@novell.com>2010-04-07 19:22:09 +0800
commit6416086f149ee7d3f267bd67d3019ef26122c07a (patch)
treec090e390a59a5d0e062271364129f2d2595263bb /configure.ac
parent6823af7d0b96a72a27159836b533e5d22130b7f2 (diff)
downloadgsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.gz
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.bz2
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.lz
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.xz
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.tar.zst
gsoc2013-evolution-6416086f149ee7d3f267bd67d3019ef26122c07a.zip
Add ConnMan support (words fail me ...)
Conflicts: configure.ac modules/Makefile.am
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7e88758f1e..3b427e0805 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1139,10 +1139,21 @@ if test "$enable_nm" = yes; then
AC_SUBST(HAVE_NM)
AC_SUBST(NM_CFLAGS)
fi
-
AM_CONDITIONAL([ENABLE_NETWORK_MANAGER], [test "$enable_nm" = yes])
dnl ******************************
+dnl Enable ConnMan support ?
+dnl ******************************
+AC_ARG_ENABLE([connman],
+ [AS_HELP_STRING([--enable-connman],
+ [enable ConnMan support (default=no)])],
+ [enable_connman=$enableval],[enable_connman=no])
+if test "x$enable_nm$enable_connman" = "xyesyes"; then
+ AC_MSG_ERROR([It is not possible to enable both ConnMan and NetworkManager])
+fi
+AM_CONDITIONAL([ENABLE_CONNMAN], [test "$enable_connman" = yes])
+
+dnl ******************************
dnl Camel Flags
dnl ******************************
EVO_SET_COMPILE_FLAGS(CAMEL, camel-provider-1.2, $MANUAL_NSS_CFLAGS, $MOXILLA_NSS_CFLAGS)
@@ -1690,6 +1701,7 @@ modules/addressbook/Makefile
modules/calendar/Makefile
modules/mail/Makefile
modules/network-manager/Makefile
+modules/connman/Makefile
modules/plugin-lib/Makefile
modules/plugin-mono/Makefile
modules/plugin-python/Makefile