aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-07-26 21:33:29 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-07-28 09:24:01 +0800
commit3eda7a50de7059e7898944d74ab1fc7c707e089b (patch)
tree7432f364f57ce7279e0939d527386e9bbd011f6d /configure.ac
parentc71f615a7f1d4f4c5df1d8a0a11af8f2319bdf20 (diff)
downloadgsoc2013-evolution-3eda7a50de7059e7898944d74ab1fc7c707e089b.tar
gsoc2013-evolution-3eda7a50de7059e7898944d74ab1fc7c707e089b.tar.gz
gsoc2013-evolution-3eda7a50de7059e7898944d74ab1fc7c707e089b.tar.bz2
gsoc2013-evolution-3eda7a50de7059e7898944d74ab1fc7c707e089b.tar.lz
gsoc2013-evolution-3eda7a50de7059e7898944d74ab1fc7c707e089b.tar.xz
gsoc2013-evolution-3eda7a50de7059e7898944d74ab1fc7c707e089b.tar.zst
gsoc2013-evolution-3eda7a50de7059e7898944d74ab1fc7c707e089b.zip
Add e_web_view_cursor_image_copy().
Asynchronously copies the image under the cursor to the clipboard. This replaces the "cursor-image" property, which attempts to match the image URI to a subresource from WebKitWebDataSource. The problem with that approach is EMailDisplay redirects several URI schemes to its own custom request handlers which further mutate the URI. So for example, a text/html message may use a "cid:" URI to refer to an embedded image, which EMailDisplay transforms to a "mail:" URI and finally to a "data:" URI. The final image URI might not be derivable from the original URI without retracing the SoupRequest. The "image-copy" action now calls e_web_view_cursor_image_copy(). This also adds an explicit requirement on gdk-pixbuf-2.0 >= 2.24 for gdk_pixbuf_new_from_stream_async() / finish(). New functions: e_web_view_cursor_image_copy() Removed functions: e_web_view_get_cursor_image() e_web_view_set_cursor_image()
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa032f246c..6b2515e36f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,7 @@ m4_define([soup_encoded_version], [SOUP_VERSION_2_40])
m4_define([eds_minimum_version], [evo_version])
m4_define([gtkhtml_minimum_version], [4.5.2])
+m4_define([gdk_pixbuf_minimum_version], [2.24.0])
m4_define([gnome_desktop_minimum_version], [2.91.3])
m4_define([gnome_icon_theme_minimum_version], [2.30.2.1])
m4_define([gsettings_desktop_schemas_minimum_version], [2.91.92])
@@ -281,6 +282,7 @@ PKG_CHECK_MODULES([GNOME_PLATFORM],
cairo-gobject
gtk+-3.0 >= gdk_minimum_version
gail-3.0 >= gdk_minimum_version
+ gdk-pixbuf-2.0 >= gdk_pixbuf_minimum_version
libxml-2.0 >= libxml_minimum_version
shared-mime-info >= shared_mime_info_minimum_version
gnome-desktop-3.0 >= gnome_desktop_minimum_version