aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaciej Piechotka <uzytkownik2@gmail.com>2010-07-04 03:09:50 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-07-04 03:10:45 +0800
commitf835af700c6d5d17516c90fe76867be365059295 (patch)
tree804f00c14a652817f97d35f553a031bba2969bbe /configure.ac
parentba606b7fef27b97c0b343b0c799dad1feacbf474 (diff)
downloadgsoc2013-evolution-f835af700c6d5d17516c90fe76867be365059295.tar
gsoc2013-evolution-f835af700c6d5d17516c90fe76867be365059295.tar.gz
gsoc2013-evolution-f835af700c6d5d17516c90fe76867be365059295.tar.bz2
gsoc2013-evolution-f835af700c6d5d17516c90fe76867be365059295.tar.lz
gsoc2013-evolution-f835af700c6d5d17516c90fe76867be365059295.tar.xz
gsoc2013-evolution-f835af700c6d5d17516c90fe76867be365059295.tar.zst
gsoc2013-evolution-f835af700c6d5d17516c90fe76867be365059295.zip
Bug 623432 - Use gweather-3.0 when building with gtk3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 60574f5d37..e664073bb1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,9 @@ if test "x${enable_gtk3}" = "xyes"; then
GTKHTML_EDITOR="gtkhtml-editor-4.0"
+ GWEATHER="gweather-3.0"
+ gweather_minimum_version="2.90.0"
+
libnotify_minimum_version="0.5.1"
dnl XXX These versions don't yet exist. The latest releases
@@ -89,7 +92,6 @@ if test "x${enable_gtk3}" = "xyes"; then
champlain_minimum_version="0.8"
clutter_gtk_minimum_version="1.0"
gtkimageview_minimum_version="2.0"
- gweather_minimum_version="2.90.0"
EVOLUTION_SHELL="evolution-shell-3.0"
else
@@ -115,10 +117,12 @@ else
GTKHTML_EDITOR="gtkhtml-editor-3.14"
+ GWEATHER="gweather"
+ gweather_minimum_version="2.25.3"
+
champlain_minimum_version="0.4"
clutter_gtk_minimum_version="0.10.0"
gtkimageview_minimum_version="1.6"
- gweather_minimum_version="2.25.3"
libnotify_minimum_version="0.3.0"
EVOLUTION_SHELL="evolution-shell"
@@ -1495,7 +1499,7 @@ AC_ARG_ENABLE([weather],
[enable_weather="$enableval"],[enable_weather=yes])
if test "x$enable_weather" = "xyes"; then
- PKG_CHECK_MODULES([LIBGWEATHER], gweather >= $gweather_minimum_version,
+ PKG_CHECK_MODULES([LIBGWEATHER], $GWEATHER >= $gweather_minimum_version,
have_weather="yes", have_weather="no")
AC_SUBST(GWEATHER_CFLAGS)
AC_SUBST(GWEATHER_LIBS)
@@ -1503,7 +1507,7 @@ if test "x$enable_weather" = "xyes"; then
if test "x$have_weather" = "xyes"; then
plugins_base="$plugins_base calendar-weather"
else
- AC_MSG_ERROR([gweather >= $gweather_minimum_version is required for the calendar-weather plugin. Use --disable-weather to exclude the plugin.])
+ AC_MSG_ERROR([$GWEATHER >= $gweather_minimum_version is required for the calendar-weather plugin. Use --disable-weather to exclude the plugin.])
fi
fi