aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSrinivasa Ragavan <sragavan@gnome.org>2010-07-16 01:09:55 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-07-26 09:30:00 +0800
commit5bcd16f4d7bd1f5fa61b00ce69c335e5451d3aae (patch)
tree2afb4a15718962c0d11ac8e8454ad6ecccd579ab /configure.ac
parentd46c4b4e5bcaefd116b0ee0e49af951c31019990 (diff)
downloadgsoc2013-evolution-5bcd16f4d7bd1f5fa61b00ce69c335e5451d3aae.tar
gsoc2013-evolution-5bcd16f4d7bd1f5fa61b00ce69c335e5451d3aae.tar.gz
gsoc2013-evolution-5bcd16f4d7bd1f5fa61b00ce69c335e5451d3aae.tar.bz2
gsoc2013-evolution-5bcd16f4d7bd1f5fa61b00ce69c335e5451d3aae.tar.lz
gsoc2013-evolution-5bcd16f4d7bd1f5fa61b00ce69c335e5451d3aae.tar.xz
gsoc2013-evolution-5bcd16f4d7bd1f5fa61b00ce69c335e5451d3aae.tar.zst
gsoc2013-evolution-5bcd16f4d7bd1f5fa61b00ce69c335e5451d3aae.zip
Option to build with clutter/MX
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 78a815db01..c578a6c958 100644
--- a/configure.ac
+++ b/configure.ac
@@ -643,6 +643,27 @@ if test x"$have_xfree" = "xyes" ; then
fi
dnl **************************************************
+dnl Clutter support.
+dnl **************************************************
+AC_MSG_CHECKING([whether to build with Clutter])
+AC_ARG_WITH([clutter],
+ [AC_HELP_STRING([--with-clutter],
+ [Build with Clutter [default=no]])],
+ with_clutter="$withval", with_clutter="no")
+AC_MSG_RESULT($with_clutter)
+
+if test "x$with_clutter" = "xyes"; then
+ PKG_CHECK_MODULES(CLUTTER, [mx-1.0 clutter-gtk-0.90 >= 0.90.0 clutter-1.0 >= 1.0.0])
+
+ AC_DEFINE(HAVE_CLUTTER, 1, [Clutter available])
+ AM_CONDITIONAL(ENABLE_CLUTTER, true)
+else
+ AC_DEFINE(HAVE_CLUTTER, 0, [Clutter not available])
+ AM_CONDITIONAL(ENABLE_CLUTTER, false)
+fi
+
+
+dnl **************************************************
dnl LDAP support.
dnl **************************************************
if test "$os_win32" != yes; then