aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorH.Habighorst <tearofadragon@googlemail.com>2009-06-20 09:41:49 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-06-24 22:29:20 +0800
commit92685c079d4a7c640488f526d273991a7ecb24d0 (patch)
treeccaaeaf0acae3e2744bc03f5b972852c1763586f /configure.ac
parentb7bf7ae3af4b831e05b212dec0962ff51daf696a (diff)
downloadgsoc2013-evolution-92685c079d4a7c640488f526d273991a7ecb24d0.tar
gsoc2013-evolution-92685c079d4a7c640488f526d273991a7ecb24d0.tar.gz
gsoc2013-evolution-92685c079d4a7c640488f526d273991a7ecb24d0.tar.bz2
gsoc2013-evolution-92685c079d4a7c640488f526d273991a7ecb24d0.tar.lz
gsoc2013-evolution-92685c079d4a7c640488f526d273991a7ecb24d0.tar.xz
gsoc2013-evolution-92685c079d4a7c640488f526d273991a7ecb24d0.tar.zst
gsoc2013-evolution-92685c079d4a7c640488f526d273991a7ecb24d0.zip
More build cleanups.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 11 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 04f936f097..cc692f9dbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,14 @@ m4_define([evo_stable_version],
[evo_major_version.m4_eval(evo_minor_version - 1)],
[evo_version])])
+# Base version : This is for api/versioning tracking for things like bonobo .server files
+# This should always be the major/minor of the stable version or stable version to be
+m4_define([base_version], [2.28])
+
+# Upgrade Revision: This is for triggering migration calls between
+# varying versions. This should be reset to 0 whenever BASE_VERSION changes.
+m4_define([upgrade_revision], [0])
+
AC_INIT(evolution, [evo_version], http://bugzilla.gnome.org/enter_bug.cgi?product=Evolution)
AC_CONFIG_SRCDIR(README)
@@ -98,26 +106,10 @@ if test "$evo_version" != "$evo_stable_version"; then
[Define to the latest stable version if this version is unstable])
fi
-dnl *************************************************************************************************
-dnl Base Version
-dnl
-dnl This is for api/versioning tracking for things like bonobo .server files
-dnl
-dnl This should always be the major/minor of the stable version or stable version to be
-dnl *************************************************************************************************
-BASE_VERSION=2.28
-AC_SUBST(BASE_VERSION)
+AC_SUBST([BASE_VERSION],[base-version])
AC_DEFINE_UNQUOTED(BASE_VERSION, "$BASE_VERSION", [Base version (Major.Minor)])
-dnl *************************************************************************************************
-dnl Upgrade Revision
-dnl
-dnl This is for triggering migration calls between varying versions.
-dnl
-dnl This should be reset to 0 whenever BASE_VERSION changes
-dnl *************************************************************************************************
-UPGRADE_REVISION=0
-AC_SUBST(UPGRADE_REVISION)
+AC_SUBST([UPGRADE_REVISION],[upgrade_revision])
AC_DEFINE_UNQUOTED(UPGRADE_REVISION, "$UPGRADE_REVISION", [The number of times we've upgraded since the BASE_VERSION release])
AC_ISC_POSIX
@@ -135,7 +127,7 @@ case $YACC in
AC_MSG_ERROR(You need bison to build Evolution)
;;
esac
-AC_STDC_HEADERS
+AC_HEADER_STDC
AC_ARG_PROGRAM
AC_PROG_INSTALL
AC_PROG_LN_S