aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2010-03-29 18:40:00 +0800
committerFridrich Štrba <fridrich.strba@bluewin.ch>2010-03-29 18:40:00 +0800
commitf60b04f24e0bf71e45ed1dc6d9dc7945681a0900 (patch)
tree574d6e420a14e972ef3e0b1902c62dfa697c064d /configure.ac
parentb947206eed3d00573bf6577d60a5f53bf5fe89e7 (diff)
downloadgsoc2013-evolution-f60b04f24e0bf71e45ed1dc6d9dc7945681a0900.tar
gsoc2013-evolution-f60b04f24e0bf71e45ed1dc6d9dc7945681a0900.tar.gz
gsoc2013-evolution-f60b04f24e0bf71e45ed1dc6d9dc7945681a0900.tar.bz2
gsoc2013-evolution-f60b04f24e0bf71e45ed1dc6d9dc7945681a0900.tar.lz
gsoc2013-evolution-f60b04f24e0bf71e45ed1dc6d9dc7945681a0900.tar.xz
gsoc2013-evolution-f60b04f24e0bf71e45ed1dc6d9dc7945681a0900.tar.zst
gsoc2013-evolution-f60b04f24e0bf71e45ed1dc6d9dc7945681a0900.zip
[win32] Some buildability tweaks for Windows SENS module
Don't try to build Windows SENS when not building for Windows. Extract the relevant COM structs and typedefs from mingw-w64 headers to allow to build the module with mingw.org toolchain and fix build breakages with Microsoft compilers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 33ced71478..0cb40c00eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1149,12 +1149,16 @@ AC_ARG_ENABLE([sens],
[AS_HELP_STRING([--enable-sens],
[enable Windows SENS support (default=yes)])],
[enable_sens=$enableval],[enable_sens=yes])
+if test "x$os_win32" = xyes; then
+ if test "x$enable_sens" = xyes; then
+ AC_CHECK_HEADER([rpc.h],[ enable_sens="yes" ],[ enable_sens="no" ])
+ fi
+else
+ enable_sens="no"
+fi
AC_MSG_CHECKING([if Windows SENS support is enabled])
AC_MSG_RESULT([$enable_sens])
if test "$enable_sens" = yes; then
- AC_CHECK_HEADERS([eventsys.h sensevts.h rpc.h],[ enable_sens="yes" ],[ enable_sens="no" ])
-fi
-if test "$enable_sens" = yes; then
SENS_LIBS="-lole32 -loleaut32 -luuid -lrpcrt4"
AC_SUBST(HAVE_SENS)
AC_SUBST(SENS_LIBS)