aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDominique Leuenberger <dominique-gnomezilla@leuenberger.net>2010-04-09 16:13:18 +0800
committerMilan Crha <mcrha@redhat.com>2010-04-09 16:13:18 +0800
commitad1de0aa0889edaa0ad9bc41c170fa84ec5536f2 (patch)
treef9f2737474b992a689f4533b0fa543bff5b6eff9 /configure.ac
parent5d362dba25a974b826a864dbfab5cd3510b77f12 (diff)
downloadgsoc2013-evolution-ad1de0aa0889edaa0ad9bc41c170fa84ec5536f2.tar
gsoc2013-evolution-ad1de0aa0889edaa0ad9bc41c170fa84ec5536f2.tar.gz
gsoc2013-evolution-ad1de0aa0889edaa0ad9bc41c170fa84ec5536f2.tar.bz2
gsoc2013-evolution-ad1de0aa0889edaa0ad9bc41c170fa84ec5536f2.tar.lz
gsoc2013-evolution-ad1de0aa0889edaa0ad9bc41c170fa84ec5536f2.tar.xz
gsoc2013-evolution-ad1de0aa0889edaa0ad9bc41c170fa84ec5536f2.tar.zst
gsoc2013-evolution-ad1de0aa0889edaa0ad9bc41c170fa84ec5536f2.zip
Bug #589393 - Configure fails to detect pilot-link utf8 capabilities
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 882dd1d3a8..bb82419c13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -656,8 +656,8 @@ if test "x$enable_pilot_conduits" = "xyes"; then
CFLAGS_save="$CFLAGS"
CFLAGS="$CFLAGS $GNOME_PILOT_CFLAGS"
- LDFLAGS_save="$LDFLAGS"
- LDFLAGS="$GNOME_PILOT_LIBS $LDFLAGS"
+ LIBS_save="$LIBS"
+ LIBS="$LIBS $GNOME_PILOT_LIBS $LDFLAGS"
AC_CACHE_CHECK([if pilot-link handles UTF-8 conversions],[ac_cv_pilot_link_utf8],
AC_RUN_IFELSE([AC_LANG_SOURCE(
@@ -677,7 +677,7 @@ if test "x$enable_pilot_conduits" = "xyes"; then
)],[ac_cv_pilot_link_utf8=yes],[ac_cv_pilot_link_utf8=no],[ac_cv_pilot_link_utf8=no]))
CFLAGS="$CFLAGS_save"
- LDFLAGS="$LDFLAGS_save"
+ LIBS="$LIBS_save"
if test "$ac_cv_pilot_link_utf8" = no; then
AC_MSG_ERROR([evolution requires pilot-link to have working UTF-8 conversion routines])