aboutsummaryrefslogtreecommitdiffstats
path: root/composer/Makefile.am
diff options
context:
space:
mode:
authorRadek Doulik <rodo@helixcode.com>2000-11-04 18:11:50 +0800
committerRadek Doulik <rodo@src.gnome.org>2000-11-04 18:11:50 +0800
commit7f7c32f6d202a2b1f9cc413bf361be91bcd47010 (patch)
treef3d634d30796ce96db4978eafd96db7e31e80c9b /composer/Makefile.am
parent1ca157384dd51c016c0631f2fa3ab8526ae5f12a (diff)
downloadgsoc2013-evolution-7f7c32f6d202a2b1f9cc413bf361be91bcd47010.tar
gsoc2013-evolution-7f7c32f6d202a2b1f9cc413bf361be91bcd47010.tar.gz
gsoc2013-evolution-7f7c32f6d202a2b1f9cc413bf361be91bcd47010.tar.bz2
gsoc2013-evolution-7f7c32f6d202a2b1f9cc413bf361be91bcd47010.tar.lz
gsoc2013-evolution-7f7c32f6d202a2b1f9cc413bf361be91bcd47010.tar.xz
gsoc2013-evolution-7f7c32f6d202a2b1f9cc413bf361be91bcd47010.tar.zst
gsoc2013-evolution-7f7c32f6d202a2b1f9cc413bf361be91bcd47010.zip
use inline images hash table
2000-11-04 Radek Doulik <rodo@helixcode.com> * listener.c (resolve_image_url): use inline images hash table * e-msg-composer.c (init): create inlined images hash table (destroy): destroy it (clear_inline_images): helper function, used from g_hash_table_foreach_remove to destroy one inline image record * e-msg-composer.h: added hash table with inlined images url -> cid info 2000-11-03 Radek Doulik <rodo@helixcode.com> * listener.c (impl_event): updated for API changed implemented image_url event (resolve_image_url): new helper function, attaches image to mail and returns new (resolved) url pointing to mime component * e-msg-composer-attachment.c (e_msg_composer_attachment_new): added conponent_id parameter * e-msg-composer-attachment-bar.c (e_msg_composer_attachment_bar_attach): added parameter content_id (add_from_file): likewise svn path=/trunk/; revision=6390
Diffstat (limited to 'composer/Makefile.am')
-rw-r--r--composer/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/composer/Makefile.am b/composer/Makefile.am
index e005697b9d..144c3f85a8 100644
--- a/composer/Makefile.am
+++ b/composer/Makefile.am
@@ -2,14 +2,15 @@
IDLS = \
Evolution-Composer.idl \
- Composer.idl \
- HTMLEditor.idl
+ Composer.idl
IDL_GENERATED = \
Composer.h \
Composer-common.c \
Composer-skels.c \
- Composer-stubs.c \
+ Composer-stubs.c
+
+HTML_EDITOR_GENERATED = \
HTMLEditor.h \
HTMLEditor-common.c \
HTMLEditor-skels.c \
@@ -20,8 +21,9 @@ selectnamesdir = $(top_srcdir)/addressbook/gui/component/select-names
$(IDL_GENERATED): $(IDLS) $(selectnamesdir)/Evolution-Addressbook-SelectNames.idl
$(ORBIT_IDL) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
-I $(selectnamesdir) -I . $(srcdir)/Composer.idl
- $(ORBIT_IDL) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
- -I $(selectnamesdir) -I . $(srcdir)/HTMLEditor.idl
+
+$(HTML_EDITOR_GENERATED): $(GTK_HTML_EDITOR_IDL)
+ $(ORBIT_IDL) `$(GNOME_CONFIG) --cflags idl` $(GTK_HTML_EDITOR_IDL)
##
@@ -58,6 +60,7 @@ INCLUDES = \
libcomposer_la_SOURCES = \
$(IDL_GENERATED) \
+ $(HTML_EDITOR_GENERATED) \
e-msg-composer-attachment-bar.c \
e-msg-composer-attachment-bar.h \
e-msg-composer-attachment.c \