aboutsummaryrefslogtreecommitdiffstats
path: root/composer/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2004-05-12 11:32:39 +0800
committerMichael Zucci <zucchi@src.gnome.org>2004-05-12 11:32:39 +0800
commitbc754690bee57ac0e66232197d9b88bc692aac79 (patch)
treea219c6bc85e858d87c0e6ea532f1a3a8102e7fbd /composer/Makefile.am
parent63ca6c19ab323142c1362afe95f6acf1259d2ecf (diff)
downloadgsoc2013-evolution-bc754690bee57ac0e66232197d9b88bc692aac79.tar
gsoc2013-evolution-bc754690bee57ac0e66232197d9b88bc692aac79.tar.gz
gsoc2013-evolution-bc754690bee57ac0e66232197d9b88bc692aac79.tar.bz2
gsoc2013-evolution-bc754690bee57ac0e66232197d9b88bc692aac79.tar.lz
gsoc2013-evolution-bc754690bee57ac0e66232197d9b88bc692aac79.tar.xz
gsoc2013-evolution-bc754690bee57ac0e66232197d9b88bc692aac79.tar.zst
gsoc2013-evolution-bc754690bee57ac0e66232197d9b88bc692aac79.zip
add for translators.
2004-05-12 Not Zed <NotZed@Ximian.com> * mail-composer-errors.xml.h: add for translators. * mail-composer-errors.xml: renamed from xml.in file. * Makefile.am: Fix for i18n build stuff. svn path=/trunk/; revision=25866
Diffstat (limited to 'composer/Makefile.am')
-rw-r--r--composer/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/composer/Makefile.am b/composer/Makefile.am
index 17d918f3ac..aee419abf9 100644
--- a/composer/Makefile.am
+++ b/composer/Makefile.am
@@ -29,10 +29,11 @@ $(HTML_EDITOR_GENERATED): $(GTKHTML_DATADIR)/Editor.idl
##
-error_in_files = mail-composer-errors.xml.in
-error_DATA = $(error_in_files:.xml.in=.xml)
+error_DATA = mail-composer-errors.xml
+error_i18n = $(error_DATA:.xml=.xml.h)
errordir = $(privdatadir)/errors
-@INTLTOOL_XML_RULE@
+%.xml.h: %.xml
+ $(top_builddir)/e-util/e-error-tool $^
idl_DATA = $(IDLS)
@@ -82,12 +83,13 @@ libcomposer_la_SOURCES = \
listener.h
EXTRA_DIST = \
- $(error_in_files) \
+ $(error_DATA) \
+ $(error_i18n) \
$(glade_DATA) \
$(IDLS) \
ChangeLog.pre-1-4
-BUILT_SOURCES = $(IDL_GENERATED) $(HTML_EDITOR_GENERATED) $(error_DATA)
+BUILT_SOURCES = $(IDL_GENERATED) $(HTML_EDITOR_GENERATED) $(error_i18n)
CLEANFILES = $(BUILT_SOURCES)
dist-hook: