aboutsummaryrefslogtreecommitdiffstats
path: root/composer/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-09-03 01:21:08 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-09-03 01:37:31 +0800
commit429234ff213ba04b6d0b02a28ed68aaa8af7c02c (patch)
tree69fd485d98a78148137ab29e5c1e8d16add7c0f1 /composer/Makefile.am
parentcccdb143a571cde36db9fe906864647aab546cff (diff)
downloadgsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.gz
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.bz2
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.lz
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.xz
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.zst
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.zip
Convert composer autosave to an EExtension.
Given the way the autosave feature was awkwardly bolted on to the composer, an EExtension seemed like a natural fit. And it helped clean up some object lifecycle hacks (and bugs). What we have now is a new module consisting of two EExtensions: EComposerAutosave extends EMsgComposer and determines when to kick off an asynchronous autosave operation. EComposerRegistry extends EShell and offers to restore orphaned autosave files on startup (which is also asynchronous now). e-autosave-utils.c holds the actual asynchronous functions and a few other miscellaneous utility functions. Source code for the new module lives in /modules/composer-autosave.
Diffstat (limited to 'composer/Makefile.am')
-rw-r--r--composer/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/composer/Makefile.am b/composer/Makefile.am
index 68a7ec142c..5caea41ee7 100644
--- a/composer/Makefile.am
+++ b/composer/Makefile.am
@@ -18,7 +18,6 @@ libcomposerinclude_HEADERS = \
e-composer-text-header.h \
e-composer-common.h \
e-composer-actions.h \
- e-composer-autosave.h \
e-msg-composer.h
libcomposer_la_CPPFLAGS = \
@@ -43,7 +42,6 @@ libcomposer_la_CPPFLAGS = \
libcomposer_la_SOURCES = \
$(libcomposerinclude_HEADERS) \
e-composer-actions.c \
- e-composer-autosave.c \
e-composer-header.c \
e-composer-header-table.c \
e-composer-from-header.c \