aboutsummaryrefslogtreecommitdiffstats
path: root/composer/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-07-08 16:30:04 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-07-08 16:30:04 +0800
commit899e079e77dbbdba0c4cff36f08eff5780b894df (patch)
tree4a69dc3bc39796be943a27af8cc946fda77eccaf /composer/Makefile.am
parentbaad423775e9b0d94d560167286e46af677deb36 (diff)
downloadgsoc2013-evolution-899e079e77dbbdba0c4cff36f08eff5780b894df.tar
gsoc2013-evolution-899e079e77dbbdba0c4cff36f08eff5780b894df.tar.gz
gsoc2013-evolution-899e079e77dbbdba0c4cff36f08eff5780b894df.tar.bz2
gsoc2013-evolution-899e079e77dbbdba0c4cff36f08eff5780b894df.tar.lz
gsoc2013-evolution-899e079e77dbbdba0c4cff36f08eff5780b894df.tar.xz
gsoc2013-evolution-899e079e77dbbdba0c4cff36f08eff5780b894df.tar.zst
gsoc2013-evolution-899e079e77dbbdba0c4cff36f08eff5780b894df.zip
Use the new controls implemented in the addressbook in the message
composer. svn path=/trunk/; revision=3973
Diffstat (limited to 'composer/Makefile.am')
-rw-r--r--composer/Makefile.am35
1 files changed, 28 insertions, 7 deletions
diff --git a/composer/Makefile.am b/composer/Makefile.am
index 0c78a7b9f3..44c19403ca 100644
--- a/composer/Makefile.am
+++ b/composer/Makefile.am
@@ -1,3 +1,22 @@
+## CORBA stuff
+
+IDLS = \
+ $(top_srcdir)/addressbook/gui/component/select-names/Evolution-Addressbook-SelectNames.idl
+
+IDL_GENERATED = \
+ Evolution-Addressbook-SelectNames.h \
+ Evolution-Addressbook-SelectNames-common.c \
+ Evolution-Addressbook-SelectNames-skels.c \
+ Evolution-Addressbook-SelectNames-stubs.c
+
+Evolution-Addressbook-SelectNames-impl.o: Evolution-Addressbook-SelectNames.h
+
+$(IDL_GENERATED): $(IDLS)
+ $(ORBIT_IDL) -I$(datadir)/idl -I`$(GNOME_CONFIG) --datadir`/idl \
+ $(top_srcdir)/addressbook/gui/component/select-names/Evolution-Addressbook-SelectNames.idl
+
+##
+
gladedir = $(datadir)/evolution/glade
glade_DATA = \
@@ -11,19 +30,21 @@ libcomposerincludedir = $(includedir)/composer
noinst_LTLIBRARIES = libcomposer.la
libcomposer_la_LDFLAGS = -static
-INCLUDES = \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- -I$(top_srcdir)/camel \
- -I$(top_builddir)/camel \
- $(GNOME_INCLUDEDIR) \
- $(BONOBO_GNOME_CFLAGS) \
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/camel \
+ -I$(top_builddir)/camel \
+ -I$(top_builddir)/addressbook/gui/component/select-names \
+ $(GNOME_INCLUDEDIR) \
+ $(BONOBO_GNOME_CFLAGS) \
-DG_LOG_DOMAIN=\"composer\"
CPPFLAGS = \
-DE_GLADEDIR=\"$(gladedir)\"
libcomposer_la_SOURCES = \
+ $(IDL_GENERATED) \
e-msg-composer-address-dialog.c \
e-msg-composer-address-dialog.h \
e-msg-composer-address-entry.c \