aboutsummaryrefslogtreecommitdiffstats
path: root/capplet/Makefile.am
diff options
context:
space:
mode:
authorSrinivasa Ragavan <sragavan@gnome.org>2010-03-02 20:30:06 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-03-14 09:49:49 +0800
commit5069df6878424605df09517e3b097c0bb47be746 (patch)
treeef630480d8ccf4342e5e06c21af3b031afc27880 /capplet/Makefile.am
parent8e0c294e15ca3f765e330b1d6ae892b768453fa9 (diff)
downloadgsoc2013-evolution-5069df6878424605df09517e3b097c0bb47be746.tar
gsoc2013-evolution-5069df6878424605df09517e3b097c0bb47be746.tar.gz
gsoc2013-evolution-5069df6878424605df09517e3b097c0bb47be746.tar.bz2
gsoc2013-evolution-5069df6878424605df09517e3b097c0bb47be746.tar.lz
gsoc2013-evolution-5069df6878424605df09517e3b097c0bb47be746.tar.xz
gsoc2013-evolution-5069df6878424605df09517e3b097c0bb47be746.tar.zst
gsoc2013-evolution-5069df6878424605df09517e3b097c0bb47be746.zip
Restructure capplet stuffs and load only on express mode.
Diffstat (limited to 'capplet/Makefile.am')
-rw-r--r--capplet/Makefile.am34
1 files changed, 2 insertions, 32 deletions
diff --git a/capplet/Makefile.am b/capplet/Makefile.am
index dd18c3e994..db32e89444 100644
--- a/capplet/Makefile.am
+++ b/capplet/Makefile.am
@@ -1,3 +1,4 @@
+SUBDIRS = settings
AM_CPPFLAGS = \
-I$(top_srcdir)/widgets \
@@ -36,29 +37,10 @@ AM_CFLAGS =\
bin_PROGRAMS = evolution-settings
-privsolib_LTLIBRARIES = libevolution-mail-settings.la
evolution_settings_SOURCES = \
anjal-settings-main.c
-libevolution_mail_settings_la_SOURCES = \
- mail-settings-view.c \
- mail-settings-view.h \
- mail-account-view.c \
- mail-account-view.h \
- mail-view.c \
- mail-view.h \
- mail-capplet-shell.c \
- mail-capplet-shell.h \
- mail-decoration.c \
- mail-decoration.h \
- anjal-mail-view.h \
- anjal-mail-view.c \
- mail-guess-servers.c \
- mail-guess-servers.h
-
-libevolution_mail_settings_la_CFLAGS = -DANJAL_SETTINGS
-
evolution_settings_LDFLAGS = \
-Wl,--export-dynamic
@@ -73,18 +55,6 @@ evolution_settings_LDADD = \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
$(top_builddir)/filter/libfilter.la \
$(top_builddir)/mail/libevolution-mail.la \
- $(top_builddir)/capplet/libevolution-mail-settings.la
-
-libevolution_mail_settings_la_LIBADD = \
- $(EVOLUTION_MAIL_LIBS) \
- $(CERT_UI_LIBS) \
- $(CANBERRA_LIBS) \
- $(GTKHTML_LIBS) \
- $(E_WIDGETS_LIBS) \
- $(SMIME_LIBS) \
- $(GNOME_PLATFORM_LIBS) \
- $(top_builddir)/widgets/misc/libemiscwidgets.la \
- $(top_builddir)/filter/libfilter.la \
- $(top_builddir)/mail/libevolution-mail.la
+ $(top_builddir)/capplet/settings/libevolution-mail-settings.la