aboutsummaryrefslogtreecommitdiffstats
path: root/camel/tests/stream/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@HelixCode.com>2000-12-05 19:50:32 +0800
committerMichael Zucci <zucchi@src.gnome.org>2000-12-05 19:50:32 +0800
commita8d65409decc86cf8d9f9ebadea28be551b3a4d2 (patch)
tree757a46fc3ee25686150e2bcdeb2a6954574d0ba3 /camel/tests/stream/Makefile.am
parent90feaa4ad02462c8e91d27070e7d8ae178771a06 (diff)
downloadgsoc2013-evolution-a8d65409decc86cf8d9f9ebadea28be551b3a4d2.tar
gsoc2013-evolution-a8d65409decc86cf8d9f9ebadea28be551b3a4d2.tar.gz
gsoc2013-evolution-a8d65409decc86cf8d9f9ebadea28be551b3a4d2.tar.bz2
gsoc2013-evolution-a8d65409decc86cf8d9f9ebadea28be551b3a4d2.tar.lz
gsoc2013-evolution-a8d65409decc86cf8d9f9ebadea28be551b3a4d2.tar.xz
gsoc2013-evolution-a8d65409decc86cf8d9f9ebadea28be551b3a4d2.tar.zst
gsoc2013-evolution-a8d65409decc86cf8d9f9ebadea28be551b3a4d2.zip
stream_flush does make sense for a substream afterall (if you have a
2000-12-05 Not Zed <NotZed@HelixCode.com> * camel-seekable-substream.c (stream_flush): stream_flush does make sense for a substream afterall (if you have a stream_write). (stream_write): Implement this. (stream_seek): Change the STREAM_END behaviour to be more sane. if bounded go from the end of the bound, if unbounded, go from the end of the parent stream. * camel-stream-mem.c (stream_read): Dont return error if reading past the end of data, just return 0. * camel-stream-fs.c (camel_stream_fs_init): Initialise the stream to be unbound. (stream_seek): Fix the logic when seeking from the end of an unbounded stream. (camel_stream_fs_new_with_fd): If the fd is invalid (-1), then return NULL immediately. (stream_seek): Range check a SEEK_END so it fits within bound_start. 2000-12-01 Not Zed <NotZed@HelixCode.com> * tests/lib/folders.c (test_folder_basic): New test to perform basic store operations on folders (taken from folders/test1). (test_folder_message_ops): Tkane the guts out of folders/test2. svn path=/trunk/; revision=6790
Diffstat (limited to 'camel/tests/stream/Makefile.am')
-rw-r--r--camel/tests/stream/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/camel/tests/stream/Makefile.am b/camel/tests/stream/Makefile.am
new file mode 100644
index 0000000000..d16f8aaa55
--- /dev/null
+++ b/camel/tests/stream/Makefile.am
@@ -0,0 +1,21 @@
+
+INCLUDES = -I$(top_srcdir)/intl -I$(top_srcdir) -I$(top_srcdir)/camel \
+ -I$(includedir) \
+ -I$(top_srcdir)/camel/tests/lib \
+ -DG_LOG_DOMAIN=\"evolution-tests\"
+
+LDADD = \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/libibex/libibex.la \
+ $(GNOME_LIBDIR) \
+ $(top_builddir)/camel/tests/lib/libcameltest.a \
+ $(GNOMEUI_LIBS) $(INTLLIBS) $(EXTRA_GNOME_LIBS)
+
+check_PROGRAMS = \
+ test1 test2 test3
+
+TESTS = test1 test2 test3
+
+
+