aboutsummaryrefslogtreecommitdiffstats
path: root/camel/tests/misc/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2001-03-26 06:55:27 +0800
committerDan Winship <danw@src.gnome.org>2001-03-26 06:55:27 +0800
commit182c699c3909ff7e052f05259bac368b72c464f3 (patch)
treeeafe49670084a3dd4b78536098969579eae38129 /camel/tests/misc/Makefile.am
parentbedb486193f38c72e20754a4d7bd28142689f1ae (diff)
downloadgsoc2013-evolution-182c699c3909ff7e052f05259bac368b72c464f3.tar
gsoc2013-evolution-182c699c3909ff7e052f05259bac368b72c464f3.tar.gz
gsoc2013-evolution-182c699c3909ff7e052f05259bac368b72c464f3.tar.bz2
gsoc2013-evolution-182c699c3909ff7e052f05259bac368b72c464f3.tar.lz
gsoc2013-evolution-182c699c3909ff7e052f05259bac368b72c464f3.tar.xz
gsoc2013-evolution-182c699c3909ff7e052f05259bac368b72c464f3.tar.zst
gsoc2013-evolution-182c699c3909ff7e052f05259bac368b72c464f3.zip
New URL parser with full RFC1808 relative URL support. Yum.
* camel-url.c (camel_url_new_with_base): New URL parser with full RFC1808 relative URL support. Yum. (camel_url_new): Wrapper around camel_url_new_with_base now. Removed the CamelException since no one ever used it... * tests/Makefile.am: add misc subdir * tests/misc/url.c: relative URL test cases from RFC 1808 * camel-session.c (camel_session_get_service): Update camel_url_new call. svn path=/trunk/; revision=8933
Diffstat (limited to 'camel/tests/misc/Makefile.am')
-rw-r--r--camel/tests/misc/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/camel/tests/misc/Makefile.am b/camel/tests/misc/Makefile.am
new file mode 100644
index 0000000000..1cbcab8c26
--- /dev/null
+++ b/camel/tests/misc/Makefile.am
@@ -0,0 +1,21 @@
+
+INCLUDES = -I$(top_srcdir)/intl -I$(top_srcdir) -I$(top_srcdir)/camel \
+ -I$(includedir) \
+ -I$(top_srcdir)/camel/tests/lib \
+ -DG_LOG_DOMAIN=\"evolution-tests\"
+
+LDADD = \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/libibex/libibex.la \
+ $(GNOME_LIBDIR) \
+ $(top_builddir)/camel/tests/lib/libcameltest.a \
+ $(GNOMEUI_LIBS) $(INTLLIBS) $(EXTRA_GNOME_LIBS)
+
+check_PROGRAMS = \
+ url
+
+TESTS = url
+
+
+