aboutsummaryrefslogtreecommitdiffstats
path: root/camel/tests/mime-filter/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2002-08-20 04:14:15 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2002-08-20 04:14:15 +0800
commit5fb3a28aba18266a1cfc3759e6fc271a86531cb8 (patch)
treee39511d1d99ab08b529ea61f43df690b1f3b0b2a /camel/tests/mime-filter/Makefile.am
parent520d7194c4837f288733b29fa69f9cdde524fe38 (diff)
downloadgsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.gz
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.bz2
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.lz
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.xz
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.zst
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.zip
Updated to pass the needed arguments to camel_init() and to init gthreads
2002-08-19 Jeffrey Stedfast <fejj@ximian.com> * tests/lib/camel-test.c (camel_test_init): Updated to pass the needed arguments to camel_init() and to init gthreads before camel (since camel expectes it to be initialised already). * tests/lib/session.c: #include <config.h> needed for ENABLE_THREADS so that sizeof (CamelSessionClass) gives the correct size. * tests/*: Updated to work with camel API changes. svn path=/trunk/; revision=17805
Diffstat (limited to 'camel/tests/mime-filter/Makefile.am')
-rw-r--r--camel/tests/mime-filter/Makefile.am47
1 files changed, 20 insertions, 27 deletions
diff --git a/camel/tests/mime-filter/Makefile.am b/camel/tests/mime-filter/Makefile.am
index d3c2a7d29f..bceee243eb 100644
--- a/camel/tests/mime-filter/Makefile.am
+++ b/camel/tests/mime-filter/Makefile.am
@@ -1,39 +1,32 @@
-INCLUDES = -I$(top_srcdir)/intl -I$(top_srcdir) -I$(top_srcdir)/camel \
- -I$(includedir) \
- -I$(top_srcdir)/camel/tests/lib \
- -DG_LOG_DOMAIN=\"evolution-tests\" \
- -DSOURCEDIR=\"$(srcdir)\"
+INCLUDES = \
+ -I$(includedir) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/e-util \
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir)/camel/tests/lib \
+ -DG_LOG_DOMAIN=\"evolution-tests\" \
+ -DSOURCEDIR=\"$(srcdir)\" \
+ $(CAMEL_CFLAGS)
LDADD = \
- $(top_builddir)/camel/libcamel.la \
- $(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/libibex/libibex.la \
- $(GNOME_LIBDIR) \
- $(top_builddir)/camel/tests/lib/libcameltest.a \
- $(GNOMEUI_LIBS) $(INTLLIBS) $(EVOLUTION_MAIL_LIBS)
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(GNOME_LIBDIR) \
+ $(top_builddir)/camel/tests/lib/libcameltest.a \
+ $(GNOMEUI_LIBS) \
+ $(INTLLIBS) \
+ $(EVOLUTION_MAIL_LIBS)
EXTRA_DIST = \
crlf-1.in \
- crlf-1.out \
- stripheader-1.in \
- stripheader-1.out \
- stripheader-2.in \
- stripheader-2.out \
- stripheader-3.in \
- stripheader-3.out \
- stripheader-4.in \
- stripheader-4.out \
- stripheader-5.in \
- stripheader-5.out \
- stripheader-6.in \
- stripheader-6.out
+ crlf-1.out
check_PROGRAMS = \
- test-crlf \
- test-stripheader
+ test-crlf
-TESTS = test-crlf test-stripheader
+TESTS = test-crlf