aboutsummaryrefslogtreecommitdiffstats
path: root/camel/tests/lib/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2002-08-20 04:14:15 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2002-08-20 04:14:15 +0800
commit5fb3a28aba18266a1cfc3759e6fc271a86531cb8 (patch)
treee39511d1d99ab08b529ea61f43df690b1f3b0b2a /camel/tests/lib/Makefile.am
parent520d7194c4837f288733b29fa69f9cdde524fe38 (diff)
downloadgsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.gz
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.bz2
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.lz
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.xz
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.tar.zst
gsoc2013-evolution-5fb3a28aba18266a1cfc3759e6fc271a86531cb8.zip
Updated to pass the needed arguments to camel_init() and to init gthreads
2002-08-19 Jeffrey Stedfast <fejj@ximian.com> * tests/lib/camel-test.c (camel_test_init): Updated to pass the needed arguments to camel_init() and to init gthreads before camel (since camel expectes it to be initialised already). * tests/lib/session.c: #include <config.h> needed for ENABLE_THREADS so that sizeof (CamelSessionClass) gives the correct size. * tests/*: Updated to work with camel API changes. svn path=/trunk/; revision=17805
Diffstat (limited to 'camel/tests/lib/Makefile.am')
-rw-r--r--camel/tests/lib/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/camel/tests/lib/Makefile.am b/camel/tests/lib/Makefile.am
index f3a92899b2..93ec07abd5 100644
--- a/camel/tests/lib/Makefile.am
+++ b/camel/tests/lib/Makefile.am
@@ -1,5 +1,11 @@
-INCLUDES = -I$(includedir) -I$(top_srcdir) -I$(top_srcdir)/camel
+INCLUDES = \
+ -I$(includedir) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/e-util \
+ -I$(top_srcdir)/camel \
+ $(CAMEL_CFLAGS)
check_LIBRARIES = libcameltest.a
@@ -12,3 +18,5 @@ libcameltest_a_SOURCES = \
streams.c streams.h \
address-data.h
+libcameltest_a_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la