aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/nntp/Makefile.am
diff options
context:
space:
mode:
authorMeilof Veeningen <meilof@wanadoo.nl>2004-01-13 06:20:40 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2004-01-13 06:20:40 +0800
commit70f49bc0d7ce40521c4c99b7c9dbe6255db2c788 (patch)
tree6a1cd1a9114c3cb5d64dfe10c6fd08f39e853b03 /camel/providers/nntp/Makefile.am
parentfb0dddb43d9b8a502c6c32dc10e6e485f35bec74 (diff)
downloadgsoc2013-evolution-70f49bc0d7ce40521c4c99b7c9dbe6255db2c788.tar
gsoc2013-evolution-70f49bc0d7ce40521c4c99b7c9dbe6255db2c788.tar.gz
gsoc2013-evolution-70f49bc0d7ce40521c4c99b7c9dbe6255db2c788.tar.bz2
gsoc2013-evolution-70f49bc0d7ce40521c4c99b7c9dbe6255db2c788.tar.lz
gsoc2013-evolution-70f49bc0d7ce40521c4c99b7c9dbe6255db2c788.tar.xz
gsoc2013-evolution-70f49bc0d7ce40521c4c99b7c9dbe6255db2c788.tar.zst
gsoc2013-evolution-70f49bc0d7ce40521c4c99b7c9dbe6255db2c788.zip
now based on discofolder, cache_message and append_message implemented,
2004-01-12 Meilof Veeningen <meilof@wanadoo.nl> * providers/nntp/camel-nntp-folder.[ch]: now based on discofolder, cache_message and append_message implemented, only retrieve messages when we are subscribed, some stubs * providers/nntp/camel-nntp-provider.c: newsgroup name display settings, password authentication, fix for check_equal where the protocols wouldn't be checked * providers/nntp/camel-nntp-store.[ch]: base on discostore with online/offline support, subscriptions, downloading changed parts of the newsgroup list, some stubs, authentication, automatic reconnect * providers/nntp/camel-nntp-store-summary.[ch]: NNTP store summary based on IMAP code * providers/nntp/camel-nntp-summary.c: save summary after xover * providers/nntp/camel-nntp-grouplist.h: added CamelNNTPGroupList structs * providers/nntp/Makefile.am: added store summary svn path=/trunk/; revision=24178
Diffstat (limited to 'camel/providers/nntp/Makefile.am')
-rw-r--r--camel/providers/nntp/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/camel/providers/nntp/Makefile.am b/camel/providers/nntp/Makefile.am
index 464624b82d..3e177226dd 100644
--- a/camel/providers/nntp/Makefile.am
+++ b/camel/providers/nntp/Makefile.am
@@ -6,6 +6,7 @@ camel_provider_LTLIBRARIES = libcamelnntp.la
camel_provider_DATA = libcamelnntp.urls
INCLUDES = -I../.. \
+ -I$(top_srcdir) \
-I$(top_srcdir)/camel \
-I$(top_srcdir)/intl \
-I$(top_srcdir)/e-util \
@@ -20,13 +21,15 @@ libcamelnntp_la_SOURCES = \
camel-nntp-store.c \
camel-nntp-folder.c \
camel-nntp-stream.c \
- camel-nntp-summary.c
+ camel-nntp-summary.c \
+ camel-nntp-store-summary.c
libcamelnntpinclude_HEADERS = \
camel-nntp-store.h \
camel-nntp-folder.h \
camel-nntp-stream.h \
- camel-nntp-summary.h
+ camel-nntp-summary.h \
+ camel-nntp-store-summary.h
noinst_HEADERS = \
camel-nntp-private.h