aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/nntp/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@helixcode.com>2000-06-23 10:03:35 +0800
committerChris Toshok <toshok@src.gnome.org>2000-06-23 10:03:35 +0800
commit61ec5b754bb8acf189d0ac083bf8e0cb0c98ebc0 (patch)
tree10f5113029f696b542b83b549d36c570f4ceee81 /camel/providers/nntp/Makefile.am
parentafa7176eab5a2c495a8f10de4c430f443cdcfb99 (diff)
downloadgsoc2013-evolution-61ec5b754bb8acf189d0ac083bf8e0cb0c98ebc0.tar
gsoc2013-evolution-61ec5b754bb8acf189d0ac083bf8e0cb0c98ebc0.tar.gz
gsoc2013-evolution-61ec5b754bb8acf189d0ac083bf8e0cb0c98ebc0.tar.bz2
gsoc2013-evolution-61ec5b754bb8acf189d0ac083bf8e0cb0c98ebc0.tar.lz
gsoc2013-evolution-61ec5b754bb8acf189d0ac083bf8e0cb0c98ebc0.tar.xz
gsoc2013-evolution-61ec5b754bb8acf189d0ac083bf8e0cb0c98ebc0.tar.zst
gsoc2013-evolution-61ec5b754bb8acf189d0ac083bf8e0cb0c98ebc0.zip
ignore test-newsrc
2000-06-22 Chris Toshok <toshok@helixcode.com> * providers/nntp/.cvsignore: ignore test-newsrc * providers/nntp/camel-nntp-store.c, providers/nntp/camel-nntp-store.h, providers/nntp/camel-nntp-folder.c, providers/nntp/camel-nntp-folder.h, providers/nntp/camel-nntp-utils.c: Bring the nntp provider up to a state where it builds and is usable with the current camel. there are still warts (semi-broken .newsrc file handling, and a lack of a subscribe ui -- in fact no way to add a new server, really), but it'll display news messages. * providers/nntp/Makefile.am (libcamelnntp_la_SOURCES): add camel-nntp-newsrc.c (libcamelnntpinclude_HEADERS): add camel-nntp-newsrc.h also, add test-newsrc stuff. * providers/nntp/test-newsrc.c: new file that tests the newsrc stuff by parsing and regurgitating a .newsrc file for a particular server. * providers/nntp/camel-nntp-newsrc.c, providers/nntp/camel-nntp-newsrc.h: new files, initial support for .newsrc files. svn path=/trunk/; revision=3702
Diffstat (limited to 'camel/providers/nntp/Makefile.am')
-rw-r--r--camel/providers/nntp/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/camel/providers/nntp/Makefile.am b/camel/providers/nntp/Makefile.am
index 48f85e836d..a205f5bb83 100644
--- a/camel/providers/nntp/Makefile.am
+++ b/camel/providers/nntp/Makefile.am
@@ -17,15 +17,28 @@ INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
libcamelnntp_la_SOURCES = \
camel-nntp-folder.c \
+ camel-nntp-newsrc.c \
camel-nntp-provider.c \
camel-nntp-store.c \
camel-nntp-utils.c
libcamelnntpinclude_HEADERS = \
camel-nntp-folder.h \
+ camel-nntp-newsrc.h \
camel-nntp-store.h
-
libcamelnntp_la_LDFLAGS = -version-info 0:0:0
EXTRA_DIST = libcamelnntp.urls
+
+noinst_PROGRAMS = test-newsrc
+
+LDADD = \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/libibex/libibex.la \
+ $(GNOME_LIBDIR) \
+ $(GNOMEUI_LIBS) $(INTLLIBS) $(EXTRA_GNOME_LIBS)
+# $(BONOBO_LIBS)
+
+test_newsrc_LDADD = libcamelnntp.la $(LDADD)