aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/nntp/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2001-11-30 11:09:38 +0800
committerMichael Zucci <zucchi@src.gnome.org>2001-11-30 11:09:38 +0800
commitd46cb0fd8d142c6dfa186db76202bb9912fbb7fa (patch)
tree09283efea0e5fd246a897b62fa211e96a858d329 /camel/providers/nntp/Makefile.am
parent1af092ec093994115d64ed30f04d11bb322aba35 (diff)
downloadgsoc2013-evolution-d46cb0fd8d142c6dfa186db76202bb9912fbb7fa.tar
gsoc2013-evolution-d46cb0fd8d142c6dfa186db76202bb9912fbb7fa.tar.gz
gsoc2013-evolution-d46cb0fd8d142c6dfa186db76202bb9912fbb7fa.tar.bz2
gsoc2013-evolution-d46cb0fd8d142c6dfa186db76202bb9912fbb7fa.tar.lz
gsoc2013-evolution-d46cb0fd8d142c6dfa186db76202bb9912fbb7fa.tar.xz
gsoc2013-evolution-d46cb0fd8d142c6dfa186db76202bb9912fbb7fa.tar.zst
gsoc2013-evolution-d46cb0fd8d142c6dfa186db76202bb9912fbb7fa.zip
Completely new implementation of NNTP.
2001-11-30 Not Zed <NotZed@Ximian.com> * providers/nntp/camel-nntp-*.c: Completely new implementation of NNTP. Doesn't support subscriptions yet (lists all folders), but should be more reliable (faster?), and has an integrated cache. * camel-exception.c (camel_exception_new): Use e_memchunks for exception blocks. (camel_exception_free): Same. * camel-data-cache.[ch]: New object for managing on-disk caches of anything that can be stored in a camel-stream. * camel-file-utils.c (camel_file_util_mkdir): New function, just a nicer place to put this (than camel-store), should be removed from camel-store. (camel_file_util_safe_filename): New function to url-encode a filename. * camel-mime-parser.c (drop_states): New func to drop the parser state to initial state. (folder_scan_init_with_fd): (folder_scan_init_with_stream): Call above func to reset state if the stream is changed on us so we can change streams to reuse a parser object. svn path=/trunk/; revision=14822
Diffstat (limited to 'camel/providers/nntp/Makefile.am')
-rw-r--r--camel/providers/nntp/Makefile.am38
1 files changed, 26 insertions, 12 deletions
diff --git a/camel/providers/nntp/Makefile.am b/camel/providers/nntp/Makefile.am
index 1244c04e52..7279c40be8 100644
--- a/camel/providers/nntp/Makefile.am
+++ b/camel/providers/nntp/Makefile.am
@@ -18,23 +18,37 @@ INCLUDES = -I../.. \
-DG_LOG_DOMAIN=\"camel-nntp-provider\"
libcamelnntp_la_SOURCES = \
- camel-nntp-auth.c \
- camel-nntp-folder.c \
- camel-nntp-grouplist.c \
- camel-nntp-newsrc.c \
camel-nntp-provider.c \
camel-nntp-store.c \
- camel-nntp-utils.c
+ camel-nntp-folder.c \
+ camel-nntp-stream.c \
+ camel-nntp-summary.c
+
+# camel-nntp-auth.c \
+# camel-nntp-folder.c \
+# camel-nntp-grouplist.c \
+# camel-nntp-newsrc.c \
+# camel-nntp-provider.c \
+# camel-nntp-store.c \
+# camel-nntp-utils.c
libcamelnntpinclude_HEADERS = \
- camel-nntp-auth.h \
- camel-nntp-folder.h \
- camel-nntp-grouplist.h \
- camel-nntp-newsrc.h \
- camel-nntp-resp-codes.h \
camel-nntp-store.h \
- camel-nntp-types.h \
- camel-nntp-utils.h
+ camel-nntp-folder.h \
+ camel-nntp-stream.h \
+ camel-nntp-summary.h
+
+# camel-nntp-auth.h \
+# camel-nntp-folder.h \
+# camel-nntp-grouplist.h \
+# camel-nntp-newsrc.h \
+# camel-nntp-resp-codes.h \
+# camel-nntp-store.h \
+# camel-nntp-types.h \
+# camel-nntp-utils.h
+
+noinst_HEADERS = \
+ camel-nntp-private.h
libcamelnntp_la_LDFLAGS = -version-info 0:0:0