aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/mh/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@HelixCode.com>2000-08-01 20:46:05 +0800
committerMichael Zucci <zucchi@src.gnome.org>2000-08-01 20:46:05 +0800
commita9309844945b699c7b5162eef47785e44789d2f1 (patch)
tree590da2a2e6c9327fcf8280f6a96291947d4ffb4f /camel/providers/mh/Makefile.am
parent60e6d0367f2782b92ce0beaf8dd45345bdbaedc1 (diff)
downloadgsoc2013-evolution-a9309844945b699c7b5162eef47785e44789d2f1.tar
gsoc2013-evolution-a9309844945b699c7b5162eef47785e44789d2f1.tar.gz
gsoc2013-evolution-a9309844945b699c7b5162eef47785e44789d2f1.tar.bz2
gsoc2013-evolution-a9309844945b699c7b5162eef47785e44789d2f1.tar.lz
gsoc2013-evolution-a9309844945b699c7b5162eef47785e44789d2f1.tar.xz
gsoc2013-evolution-a9309844945b699c7b5162eef47785e44789d2f1.tar.zst
gsoc2013-evolution-a9309844945b699c7b5162eef47785e44789d2f1.zip
Initial cut at mh provider. Well, it already does everything
mbox does. 2000-08-01 Not Zed <NotZed@HelixCode.com> * providers/mh: New mh provider implementation. * providers/Makefile.am (SUBDIRS): Added mh provider. svn path=/trunk/; revision=4444
Diffstat (limited to 'camel/providers/mh/Makefile.am')
-rw-r--r--camel/providers/mh/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/camel/providers/mh/Makefile.am b/camel/providers/mh/Makefile.am
new file mode 100644
index 0000000000..62f447171b
--- /dev/null
+++ b/camel/providers/mh/Makefile.am
@@ -0,0 +1,39 @@
+## Process this file with automake to produce Makefile.in
+
+libcamelmhincludedir = $(includedir)/camel
+
+
+providerdir = $(pkglibdir)/camel-providers/$(VERSION)
+
+provider_LTLIBRARIES = libcamelmh.la
+provider_DATA = libcamelmh.urls
+
+INCLUDES = -I.. \
+ -I$(srcdir)/.. \
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/libibex \
+ -I$(top_srcdir)/e-util \
+ -I$(top_srcdir) \
+ -I$(includedir) \
+ $(GTK_INCLUDEDIR) \
+ -DG_LOG_DOMAIN=\"camel-mh-provider\"
+
+libcamelmh_la_SOURCES = \
+ camel-mh-folder.c \
+ camel-mh-provider.c \
+ camel-mh-store.c \
+ camel-mh-summary.c
+
+libcamelmhinclude_HEADERS = \
+ camel-mh-folder.h \
+ camel-mh-store.h \
+ camel-mh-summary.h
+
+libcamelmh_la_LDFLAGS = -version-info 0:0:0
+
+libcamelmh_la_LIBADD = $(top_builddir)/e-util/libeutil.la $(top_builddir)/libibex/libibex.la $(UNICODE_LIBS)
+#libcamelmh_la_LIBADD = $(top_builddir)/libibex/libibex.la $(UNICODE_LIBS)
+
+EXTRA_DIST = libcamelmh.urls
+