aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/mbox/Makefile.am
diff options
context:
space:
mode:
authorMiguel de Icaza <miguel@gnu.org>2000-02-16 01:28:34 +0800
committerArturo Espinosa <unammx@src.gnome.org>2000-02-16 01:28:34 +0800
commitd53eea370b1a53cbae519c92fa602d0e7aa5ecc8 (patch)
tree610202886dae8219e74e4e83e344d735c16a6c4a /camel/providers/mbox/Makefile.am
parentf9cdc1e00912852e94f454b0de79d613df46c19d (diff)
downloadgsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.gz
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.bz2
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.lz
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.xz
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.tar.zst
gsoc2013-evolution-d53eea370b1a53cbae519c92fa602d0e7aa5ecc8.zip
Add the unicode libraries as well.
2000-02-14 Miguel de Icaza <miguel@gnu.org> * camel/providers/mbox/Makefile.am (libcamelmbox_la_LIBADD): Add the unicode libraries as well. * camel/camel-provider.c (camel_provider_register_as_module): Add error reporting here. Desire to use Solaris increases. Hair loss in the last two hours: 5,400. * camel/providers/mbox/camel-mbox-provider.c (camel_mbox_get_provider): Renamed function. * camel/camel.h: All include files use camel/ now here. * camel/providers/mbox/Makefile.am: Drop all the dynamism from Camel, and make this a standard library. * configure.in: set the UNICODE_LIBS variable here. 2000-02-14 Miguel de Icaza <miguel@gnu.org> * folder-browser.c (folder_browser_load_folder): New routine, loads a camel folder. (folder_browser_set_uri): redo. * session.c: new file. Implements SessionStores to keep track of a Session/Store tuple. svn path=/trunk/; revision=1783
Diffstat (limited to 'camel/providers/mbox/Makefile.am')
-rw-r--r--camel/providers/mbox/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/camel/providers/mbox/Makefile.am b/camel/providers/mbox/Makefile.am
index 9b5b40ff84..c89d38db94 100644
--- a/camel/providers/mbox/Makefile.am
+++ b/camel/providers/mbox/Makefile.am
@@ -4,8 +4,9 @@ SUBDIRS =
libcamelmboxincludedir = $(includedir)/camel
+providerdir = $(libdir)/evolution/camel-providers/$(VERSION)
-lib_LTLIBRARIES = libcamelmbox.la
+provider_LTLIBRARIES = libcamelmbox.la
INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
-I$(top_srcdir)/intl \
@@ -30,9 +31,9 @@ libcamelmboxinclude_HEADERS = \
camel-mbox-utils.h
-libcamelmbox_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
+libcamelmbox_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
#libcamelmbox_la_LIBADD = -L$(top_srcdir)/libibex -libex
-libcamelmbox_la_LIBADD = $(top_srcdir)/libibex/libibex.la
+libcamelmbox_la_LIBADD = $(top_srcdir)/libibex/libibex.la $(UNICODE_LIBS)
EXTRA_DIST =