aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/mbox/Makefile.am
diff options
context:
space:
mode:
authorbertrand <bertrand@helixcode.com>2000-01-19 03:29:48 +0800
committerBertrand Guiheneuf <bertrand@src.gnome.org>2000-01-19 03:29:48 +0800
commit5e4695e7178c12d47fb5f758e203256cabbc3823 (patch)
tree30e5e311d14e651981aa5d9d178bb7c1e64676c1 /camel/providers/mbox/Makefile.am
parent64046a6665df493b03a057c7e66f4d84c4b4ba21 (diff)
downloadgsoc2013-evolution-5e4695e7178c12d47fb5f758e203256cabbc3823.tar
gsoc2013-evolution-5e4695e7178c12d47fb5f758e203256cabbc3823.tar.gz
gsoc2013-evolution-5e4695e7178c12d47fb5f758e203256cabbc3823.tar.bz2
gsoc2013-evolution-5e4695e7178c12d47fb5f758e203256cabbc3823.tar.lz
gsoc2013-evolution-5e4695e7178c12d47fb5f758e203256cabbc3823.tar.xz
gsoc2013-evolution-5e4695e7178c12d47fb5f758e203256cabbc3823.tar.zst
gsoc2013-evolution-5e4695e7178c12d47fb5f758e203256cabbc3823.zip
summary file read/write routines.
2000-01-18 bertrand <bertrand@helixcode.com> * camel/providers/mbox/camel-mbox-summary.c (camel_mbox_save_summary): (mbox_load_summary): summary file read/write routines. * camel/providers/mbox/camel-mbox-utils.c (parsed_information_to_mbox_summary): routine to construct the summary after the mbox file has been parsed and the x-evolution fields inserted. * camel/providers/mbox/camel-mbox-utils.c (camel_mbox_write_xev): dont use the x_evolution field but rather the uid to determine the presence of "X-Evolution" in the mail. * camel/providers/mbox/camel-mbox-parser.c (camel_mbox_parse_file): parse the status and uid values if the x-evolution has been found. * camel/providers/mbox/camel-mbox-utils.c (camel_mbox_xev_parse_header_content): return the parsed status field correctly. * camel/providers/mbox/camel-mbox-utils.h: fixed bad prototype. * camel/providers/mbox/camel-mbox-parser.c (camel_mbox_parse_file): parse and store the "To:" header. * camel/providers/mbox/camel-mbox-parser.h: added a "to" field * camel/camel-folder-summary.c: create the arrays here. * camel/camel-folder-summary.h: the list of summary information is no longer a GList but rather a GArray. Parsing/summary/sync-check is here. Needs testing and integration with the rest of the folder code. svn path=/trunk/; revision=1589
Diffstat (limited to 'camel/providers/mbox/Makefile.am')
-rw-r--r--camel/providers/mbox/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/camel/providers/mbox/Makefile.am b/camel/providers/mbox/Makefile.am
index 247ce55f1d..5dffdc4eff 100644
--- a/camel/providers/mbox/Makefile.am
+++ b/camel/providers/mbox/Makefile.am
@@ -13,14 +13,16 @@ INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
libcamelmbox_la_SOURCES = \
camel-mbox-folder.c \
- camel-mbox-store.c \
camel-mbox-parser.c \
+ camel-mbox-store.c \
+ camel-mbox-summary.c \
camel-mbox-utils.c
libcamelmboxinclude_HEADERS = \
camel-mbox-folder.h \
- camel-mbox-store.h \
camel-mbox-parser.h \
+ camel-mbox-store.h \
+ camel-mbox-summary.h \
camel-mbox-utils.h