aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/mbox/Makefile.am
diff options
context:
space:
mode:
authorNotZed <NotZed@HelixCode.com>2000-02-19 12:12:40 +0800
committerMichael Zucci <zucchi@src.gnome.org>2000-02-19 12:12:40 +0800
commit1c70e0090563eb9acfbcd59dcecbc833154d3747 (patch)
tree8cd04cf8629ba676bfd1979021250d31acb401f3 /camel/providers/mbox/Makefile.am
parentf1e7572b78fe6bda6b1e76457a7637de07a9842c (diff)
downloadgsoc2013-evolution-1c70e0090563eb9acfbcd59dcecbc833154d3747.tar
gsoc2013-evolution-1c70e0090563eb9acfbcd59dcecbc833154d3747.tar.gz
gsoc2013-evolution-1c70e0090563eb9acfbcd59dcecbc833154d3747.tar.bz2
gsoc2013-evolution-1c70e0090563eb9acfbcd59dcecbc833154d3747.tar.lz
gsoc2013-evolution-1c70e0090563eb9acfbcd59dcecbc833154d3747.tar.xz
gsoc2013-evolution-1c70e0090563eb9acfbcd59dcecbc833154d3747.tar.zst
gsoc2013-evolution-1c70e0090563eb9acfbcd59dcecbc833154d3747.zip
Added exception to call, and fixed caller.
2000-02-18 NotZed <NotZed@HelixCode.com> * providers/mbox/camel-mbox-search.h (camel_mbox_folder_search_by_expression): Added exception to call, and fixed caller. * providers/mbox/camel-mbox-search.c (camel_mbox_folder_search_by_expression): Major changes, to use the sexp evaluator from filter/filter-sexp.c to implement the searching. (func_body_contains): Changed to support multiple strings in 1 command (results or'd together) * url-util.c (g_url_new): Fixed a typo (colon == 0 isn't right), and made it so full url's are absolute pathed (Dan, this is how it has to work!). Also, always include a path part, even if it is an empty string. 2000-02-16 NotZed <NotZed@HelixCode.com> * providers/mbox/Makefile.am (libcamelmbox_la_LIBADD): Added libfilter to link line (temporarily?). Required for filter-sexp. svn path=/trunk/; revision=1855
Diffstat (limited to 'camel/providers/mbox/Makefile.am')
-rw-r--r--camel/providers/mbox/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/camel/providers/mbox/Makefile.am b/camel/providers/mbox/Makefile.am
index 4edbb945af..11e004a5ea 100644
--- a/camel/providers/mbox/Makefile.am
+++ b/camel/providers/mbox/Makefile.am
@@ -12,7 +12,8 @@ provider_LTLIBRARIES = libcamelmbox.la
INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
-I$(top_srcdir)/intl \
$(GTK_INCLUDEDIR) -I$(top_srcdir)/camel \
- -I$(top_srcdir)/libibex
+ -I$(top_srcdir)/libibex \
+ -I$(top_srcdir)/filter
libcamelmbox_la_SOURCES = \
camel-mbox-folder.c \
@@ -34,7 +35,12 @@ libcamelmboxinclude_HEADERS = \
libcamelmbox_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
-libcamelmbox_la_LIBADD = -L$(top_builddir)/libibex -libex
+#libcamelmbox_la_LIBADD = -L$(top_srcdir)/libibex -libex
+libcamelmbox_la_LIBADD = $(top_srcdir)/filter/libfilter.la
+##libcamelmbox_la_LIBADD = -L$(top_builddir)/libibex -libex
+##libcamelmbox_la_LIBADD = $(top_builddir)/libibex/libibex.la $(UNICODE_LIBS)
+##libcamelmbox_la_LIBADD = $(UNICODE_LIBS)
+#libcamelmbox_la_LIBADD = -L$(top_builddir)/libibex -libex
#libcamelmbox_la_LIBADD = $(top_builddir)/libibex/libibex.la $(UNICODE_LIBS)
#libcamelmbox_la_LIBADD = $(UNICODE_LIBS)