aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/local/Makefile.am
diff options
context:
space:
mode:
authorMichael Zucci <zucchi@src.gnome.org>2000-11-15 11:04:12 +0800
committerMichael Zucci <zucchi@src.gnome.org>2000-11-15 11:04:12 +0800
commit1593182b1ca1a76dbf65b5ba1700f1f0d56e097d (patch)
treee90d940af1e2250a92f13ca06358dbc4881d5cee /camel/providers/local/Makefile.am
parentd266df61cc2439fc72aede6042bf2acf743ee2ee (diff)
downloadgsoc2013-evolution-1593182b1ca1a76dbf65b5ba1700f1f0d56e097d.tar
gsoc2013-evolution-1593182b1ca1a76dbf65b5ba1700f1f0d56e097d.tar.gz
gsoc2013-evolution-1593182b1ca1a76dbf65b5ba1700f1f0d56e097d.tar.bz2
gsoc2013-evolution-1593182b1ca1a76dbf65b5ba1700f1f0d56e097d.tar.lz
gsoc2013-evolution-1593182b1ca1a76dbf65b5ba1700f1f0d56e097d.tar.xz
gsoc2013-evolution-1593182b1ca1a76dbf65b5ba1700f1f0d56e097d.tar.zst
gsoc2013-evolution-1593182b1ca1a76dbf65b5ba1700f1f0d56e097d.zip
Initial cut for local provider, to handle mh/mailbox/maildir at
least. Checking in to make a backup. svn path=/trunk/; revision=6575
Diffstat (limited to 'camel/providers/local/Makefile.am')
-rw-r--r--camel/providers/local/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/camel/providers/local/Makefile.am b/camel/providers/local/Makefile.am
new file mode 100644
index 0000000000..01a3072cb9
--- /dev/null
+++ b/camel/providers/local/Makefile.am
@@ -0,0 +1,48 @@
+## Process this file with automake to produce Makefile.in
+
+libcamellocalincludedir = $(includedir)/camel
+
+providerdir = $(pkglibdir)/camel-providers/$(VERSION)
+
+provider_LTLIBRARIES = libcamellocal.la
+provider_DATA = libcamellocal.urls
+
+INCLUDES = -I.. \
+ -I$(srcdir)/.. \
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/libibex \
+ -I$(top_srcdir)/e-util \
+ -I$(top_srcdir) \
+ -I$(includedir) \
+ $(GTK_INCLUDEDIR) \
+ -DG_LOG_DOMAIN=\"camel-local-provider\"
+
+libcamellocal_la_SOURCES = \
+ camel-local-folder.c \
+ camel-local-store.c \
+ camel-local-summary.c \
+ camel-local-provider.c \
+ camel-mh-folder.c \
+ camel-mh-store.c \
+ camel-mh-summary.c \
+ camel-mbox-folder.c \
+ camel-mbox-store.c \
+ camel-mbox-summary.c
+
+libcamellocalinclude_HEADERS = \
+ camel-local-folder.h \
+ camel-local-store.h \
+ camel-local-summary.h \
+ camel-mh-folder.h \
+ camel-mh-store.h \
+ camel-mh-summary.h \
+ camel-mbox-folder.h \
+ camel-mbox-store.h \
+ camel-mbox-summary.h
+
+libcamellocal_la_LDFLAGS = -version-info 0:0:0
+
+libcamellocal_la_LIBADD = $(top_builddir)/e-util/libeutil.la $(top_builddir)/libibex/libibex.la $(UNICODE_LIBS)
+
+EXTRA_DIST = libcamellocal.urls