aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/imap/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-10-31 01:00:06 +0800
committerDan Winship <danw@src.gnome.org>2000-10-31 01:00:06 +0800
commitdd50048ab4db6cf804c3fc59b55a8ed140f45631 (patch)
tree8e71092987d62fb400aec01e9ad6bc419ca92ae3 /camel/providers/imap/Makefile.am
parentabe39be1720a9ae3fd3402a5a8b777473319fbdb (diff)
downloadgsoc2013-evolution-dd50048ab4db6cf804c3fc59b55a8ed140f45631.tar
gsoc2013-evolution-dd50048ab4db6cf804c3fc59b55a8ed140f45631.tar.gz
gsoc2013-evolution-dd50048ab4db6cf804c3fc59b55a8ed140f45631.tar.bz2
gsoc2013-evolution-dd50048ab4db6cf804c3fc59b55a8ed140f45631.tar.lz
gsoc2013-evolution-dd50048ab4db6cf804c3fc59b55a8ed140f45631.tar.xz
gsoc2013-evolution-dd50048ab4db6cf804c3fc59b55a8ed140f45631.tar.zst
gsoc2013-evolution-dd50048ab4db6cf804c3fc59b55a8ed140f45631.zip
New file with code for IMAP authentication mechanisms. (Currently just
* providers/imap/camel-imap-auth.c: New file with code for IMAP authentication mechanisms. (Currently just krb4, and without integrity/privacy protection). * providers/imap/Makefile.am: Add camel-imap-auth.[ch] and krb4 CFLAGS/LDFLAGS * providers/imap/camel-imap-store.c (connect_to_server): Split out from imap_connect. Just does the basic connect and CAPABILITY check. Redo the CAPABILITY code more robustly. (query_auth_types_connected): Do this right rather than punting to query_auth_types_generic. Check for KERBEROS_V4 if compiled with krb4 support. (query_auth_types_generic): Mention KERBEROS_V4 if compiled with krb4 support. (imap_connect): Use connect_to_server(). svn path=/trunk/; revision=6272
Diffstat (limited to 'camel/providers/imap/Makefile.am')
-rw-r--r--camel/providers/imap/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/camel/providers/imap/Makefile.am b/camel/providers/imap/Makefile.am
index a6f5cbf3b1..19646f1960 100644
--- a/camel/providers/imap/Makefile.am
+++ b/camel/providers/imap/Makefile.am
@@ -17,9 +17,11 @@ INCLUDES = -I.. \
-I$(top_srcdir) \
-I$(includedir) \
$(GTK_INCLUDEDIR) \
+ $(KRB4_CFLAGS) \
-DG_LOG_DOMAIN=\"camel-imap-provider\"
libcamelimap_la_SOURCES = \
+ camel-imap-auth.c \
camel-imap-command.c \
camel-imap-folder.c \
camel-imap-provider.c \
@@ -28,6 +30,7 @@ libcamelimap_la_SOURCES = \
camel-imap-utils.c
libcamelimapinclude_HEADERS = \
+ camel-imap-auth.h \
camel-imap-command.h \
camel-imap-folder.h \
camel-imap-store.h \
@@ -35,7 +38,7 @@ libcamelimapinclude_HEADERS = \
camel-imap-summary.h \
camel-imap-utils.h
-libcamelimap_la_LDFLAGS = -version-info 0:0:0
+libcamelimap_la_LDFLAGS = $(KRB4_LDFLAGS) -version-info 0:0:0
EXTRA_DIST = libcamelimap.urls