aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/imap/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2001-01-17 08:27:19 +0800
committerDan Winship <danw@src.gnome.org>2001-01-17 08:27:19 +0800
commit8ad855fef6632e32723242fda554fce04f025036 (patch)
treefea4a94685bb6504bb679111f0e9e84e0f9ad835 /camel/providers/imap/Makefile.am
parent35edf4f02ace2559daea85c11c8f36efc7fe0b80 (diff)
downloadgsoc2013-evolution-8ad855fef6632e32723242fda554fce04f025036.tar
gsoc2013-evolution-8ad855fef6632e32723242fda554fce04f025036.tar.gz
gsoc2013-evolution-8ad855fef6632e32723242fda554fce04f025036.tar.bz2
gsoc2013-evolution-8ad855fef6632e32723242fda554fce04f025036.tar.lz
gsoc2013-evolution-8ad855fef6632e32723242fda554fce04f025036.tar.xz
gsoc2013-evolution-8ad855fef6632e32723242fda554fce04f025036.tar.zst
gsoc2013-evolution-8ad855fef6632e32723242fda554fce04f025036.zip
Delayed loading of IMAP message parts.
* camel-types.h: typedef CamelMessageInfo and CamelMessageContentInfo here * camel-folder-summary.h: Add a "size" field to CamelMessageContentInfo. * camel-folder-summary.c (camel_folder_summary_content_info_new, camel_folder_summary_content_info_free): Renamed and made non-static for providers that construct their own content info. (content_info_load, content_info_save): load/save size * camel-data-wrapper.c (camel_data_wrapper_is_offline): New function to return if a data wrapper's contents are "offline". (So that, for example, we don't make thumbnails of images that haven't been loaded off the IMAP server yet.) Defaults to FALSE. * providers/imap/camel-imap-folder.c (camel_imap_folder_selected): Fix a bug in re-selecting a folder when messages have been expunged from it by another client in the meantime. (imap_get_message): Rewrite. If the message is larger than a certain size, just create a skeleton message containing CamelImapWrappers that will read parts as needed. This way, large attachments only need to be downloaded if the user looks at them, and multipart/alternative alternatives that aren't used will never be downloaded at all. (imap_update_summary): Rewrite this a bunch too to make the parsing more robust. * providers/imap/camel-imap-summary.c (CAMEL_IMAP_SUMMARY_VERSION): bump. (camel_imap_summary_new): Set build_content to TRUE. (content_info_load, content_info_save): Only save/load the content for messages that have it. (The content info gets created as a side effect of imap_get_message.) * providers/imap/camel-imap-utils.c (imap_parse_body): New routine (and helpers) to parse an IMAP 'body' FETCH response and fill in a CamelMessageContentInfo from it. * providers/imap/Makefile.am (libcamelimap_la_SOURCES, libcamelimap_la_HEADERS): add camel-imap-wrapper. svn path=/trunk/; revision=7557
Diffstat (limited to 'camel/providers/imap/Makefile.am')
-rw-r--r--camel/providers/imap/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/camel/providers/imap/Makefile.am b/camel/providers/imap/Makefile.am
index aa34eac652..341fa6b421 100644
--- a/camel/providers/imap/Makefile.am
+++ b/camel/providers/imap/Makefile.am
@@ -28,7 +28,8 @@ libcamelimap_la_SOURCES = \
camel-imap-search.c \
camel-imap-store.c \
camel-imap-summary.c \
- camel-imap-utils.c
+ camel-imap-utils.c \
+ camel-imap-wrapper.c
libcamelimapinclude_HEADERS = \
camel-imap-auth.h \
@@ -38,7 +39,8 @@ libcamelimapinclude_HEADERS = \
camel-imap-store.h \
camel-imap-summary.h \
camel-imap-types.h \
- camel-imap-utils.h
+ camel-imap-utils.h \
+ camel-imap-wrapper.h
libcamelimap_la_LDFLAGS = $(KRB4_LDFLAGS) -version-info 0:0:0