aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/imap/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2001-03-02 06:39:52 +0800
committerDan Winship <danw@src.gnome.org>2001-03-02 06:39:52 +0800
commit17d6ee994369ec0acf4e30cf74d251522a109890 (patch)
tree62cd9cc5fe1d787ed239bb906c27cf15fac7fe71 /camel/providers/imap/Makefile.am
parent61a496ffcad857b0dac176861206c4a98edc1620 (diff)
downloadgsoc2013-evolution-17d6ee994369ec0acf4e30cf74d251522a109890.tar
gsoc2013-evolution-17d6ee994369ec0acf4e30cf74d251522a109890.tar.gz
gsoc2013-evolution-17d6ee994369ec0acf4e30cf74d251522a109890.tar.bz2
gsoc2013-evolution-17d6ee994369ec0acf4e30cf74d251522a109890.tar.lz
gsoc2013-evolution-17d6ee994369ec0acf4e30cf74d251522a109890.tar.xz
gsoc2013-evolution-17d6ee994369ec0acf4e30cf74d251522a109890.tar.zst
gsoc2013-evolution-17d6ee994369ec0acf4e30cf74d251522a109890.zip
Add an "authtypes" hash table to CamelImapStore recording the supported
* providers/imap/camel-imap-store.c: Add an "authtypes" hash table to CamelImapStore recording the supported authtypes. (connect_to_server): Record supported authtypes in the authtypes hash rather than the capabilities bitmask, since now the IMAP code is no longer responsible for keeping track of which authtypes we support. (query_auth_types): Use camel_sasl_authtype_list to get the SASL-supported authtypes. (try_auth): New function to try a SASL auth mechanism. Sort of formerly imap_try_kerberos_v4_auth. (imap_connect): Get rid of the krb4-specific bits and genericize them for any SASL authtype. * providers/imap/Makefile.am: Remove camel-imap-auth.[ch] (moved into camel-imap-store.c since it's now constant size) and the KRB4_CFLAGS and KRB4_LDFLAGS references. svn path=/trunk/; revision=8463
Diffstat (limited to 'camel/providers/imap/Makefile.am')
-rw-r--r--camel/providers/imap/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/camel/providers/imap/Makefile.am b/camel/providers/imap/Makefile.am
index 341fa6b421..39e160c879 100644
--- a/camel/providers/imap/Makefile.am
+++ b/camel/providers/imap/Makefile.am
@@ -17,11 +17,9 @@ INCLUDES = -I.. \
-I$(top_srcdir) \
-I$(includedir) \
$(GTK_INCLUDEDIR) \
- $(KRB4_CFLAGS) \
-DG_LOG_DOMAIN=\"camel-imap-provider\"
libcamelimap_la_SOURCES = \
- camel-imap-auth.c \
camel-imap-command.c \
camel-imap-folder.c \
camel-imap-provider.c \
@@ -32,7 +30,6 @@ libcamelimap_la_SOURCES = \
camel-imap-wrapper.c
libcamelimapinclude_HEADERS = \
- camel-imap-auth.h \
camel-imap-command.h \
camel-imap-folder.h \
camel-imap-search.h \
@@ -42,7 +39,7 @@ libcamelimapinclude_HEADERS = \
camel-imap-utils.h \
camel-imap-wrapper.h
-libcamelimap_la_LDFLAGS = $(KRB4_LDFLAGS) -version-info 0:0:0
+libcamelimap_la_LDFLAGS = -version-info 0:0:0
noinst_HEADERS = \
camel-imap-private.h