aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/imap/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-10-04 04:06:14 +0800
committerDan Winship <danw@src.gnome.org>2000-10-04 04:06:14 +0800
commit00f2a8d64eca2fdaf0f1569d9ccda5c869ab9cfb (patch)
tree98d3681d5e029b277fb83dd15e6bbbae07edfc53 /camel/providers/imap/Makefile.am
parent9a0fc2bc8d97cba38a3d1417d80e16bb9de165ce (diff)
downloadgsoc2013-evolution-00f2a8d64eca2fdaf0f1569d9ccda5c869ab9cfb.tar
gsoc2013-evolution-00f2a8d64eca2fdaf0f1569d9ccda5c869ab9cfb.tar.gz
gsoc2013-evolution-00f2a8d64eca2fdaf0f1569d9ccda5c869ab9cfb.tar.bz2
gsoc2013-evolution-00f2a8d64eca2fdaf0f1569d9ccda5c869ab9cfb.tar.lz
gsoc2013-evolution-00f2a8d64eca2fdaf0f1569d9ccda5c869ab9cfb.tar.xz
gsoc2013-evolution-00f2a8d64eca2fdaf0f1569d9ccda5c869ab9cfb.tar.zst
gsoc2013-evolution-00f2a8d64eca2fdaf0f1569d9ccda5c869ab9cfb.zip
New file containing camel_imap_command and friends. Major
* providers/imap/camel-imap-command.c: New file containing camel_imap_command and friends. Major camel_imap_command rewrite to remove duplicated code, make the parsing of literals be more safe/correct, deal with RECENT/EXPUNGE responses more consistently, and make it possible to implement the AUTHENTICATE command. * providers/imap/camel-imap-utils.c (imap_parse_nstring): New function, to parse an IMAP "nstring". * providers/imap/camel-imap-store.c: Move command stuff to camel-imap-command.c. Update for camel_imap_command changes. * providers/imap/camel-imap-folder.c: Update for camel_imap_command changes. (imap_append_message): CRLF filter the message before sending it. * providers/imap/Makefile.am: Add camel-imap-command.[ch], remove camel-imap-stream.[ch] for now. svn path=/trunk/; revision=5693
Diffstat (limited to 'camel/providers/imap/Makefile.am')
-rw-r--r--camel/providers/imap/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/camel/providers/imap/Makefile.am b/camel/providers/imap/Makefile.am
index 5ff249739f..15e1b850e8 100644
--- a/camel/providers/imap/Makefile.am
+++ b/camel/providers/imap/Makefile.am
@@ -20,16 +20,16 @@ INCLUDES = -I.. \
-DG_LOG_DOMAIN=\"camel-imap-provider\"
libcamelimap_la_SOURCES = \
+ camel-imap-command.c \
camel-imap-folder.c \
camel-imap-provider.c \
camel-imap-store.c \
- camel-imap-stream.c \
camel-imap-utils.c
libcamelimapinclude_HEADERS = \
+ camel-imap-command.h \
camel-imap-folder.h \
camel-imap-store.h \
- camel-imap-stream.h \
camel-imap-utils.h
libcamelimap_la_LDFLAGS = -version-info 0:0:0