aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorNotZed <NotZed@HelixCode.com>2000-05-05 11:46:07 +0800
committerMichael Zucci <zucchi@src.gnome.org>2000-05-05 11:46:07 +0800
commit214c9105509631c39c4d9b60572ee32f0d6d7ea3 (patch)
tree611b14c8989668df11fa2c714ff13675e1406f3f /camel/Makefile.am
parent241a35c42fc0e5287b25bc4980415b0e1e61f422 (diff)
downloadgsoc2013-evolution-214c9105509631c39c4d9b60572ee32f0d6d7ea3.tar
gsoc2013-evolution-214c9105509631c39c4d9b60572ee32f0d6d7ea3.tar.gz
gsoc2013-evolution-214c9105509631c39c4d9b60572ee32f0d6d7ea3.tar.bz2
gsoc2013-evolution-214c9105509631c39c4d9b60572ee32f0d6d7ea3.tar.lz
gsoc2013-evolution-214c9105509631c39c4d9b60572ee32f0d6d7ea3.tar.xz
gsoc2013-evolution-214c9105509631c39c4d9b60572ee32f0d6d7ea3.tar.zst
gsoc2013-evolution-214c9105509631c39c4d9b60572ee32f0d6d7ea3.zip
Maxcount is minimum of the max and the requested count, not the maximum :)
2000-05-04 NotZed <NotZed@HelixCode.com> * providers/mbox/camel-mbox-folder.c (summary_get_message_info): Maxcount is minimum of the max and the requested count, not the maximum :) * camel-mime-parser.c (folder_scan_content): Properly set midline, so we dont falsely catch offset boundary markers (i.e. From inside content). (folder_read): Set a sentinal on the end of the read data (\n) so we dont have to check the buffer boundary in the inner loop. (mempool_*): New experimental memory management routines, speed up simple structure parsing by about 25% ... not compiled in by default. Something similar may be needed for camel-mime-utils to address performance issues with g_malloc and friends. * camel-mime-utils.c: Added a macro w(x) used to wrap all warnings about mime/rfc violations, so they can be turned off. * camel-folder-summary.c (summary_build_content_info): Step after the end of a message ... Turn into a stand-alone program for testing and profiling. svn path=/trunk/; revision=2808
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 513cd25648..c3948235ed 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -38,7 +38,6 @@ libcamel_la_SOURCES = \
camel-exception.c \
camel-folder.c \
camel-folder-search.c \
- camel-folder-summary.c \
camel-medium.c \
camel-marshal-utils.c \
camel-mime-message.c \
@@ -76,13 +75,15 @@ libcamel_la_SOURCES = \
camel-internet-address.c \
$(pthread_SRC)
+# camel-folder-summary.c \
+# camel-folder-summary.h \
+
libcamelinclude_HEADERS = \
camel.h \
camel-data-wrapper.h \
camel-exception.h \
camel-folder.h \
camel-folder-search.h \
- camel-folder-summary.h \
camel-marshal-utils.h \
camel-medium.h \
camel-mime-message.h \
@@ -129,3 +130,20 @@ libcamel_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
EXTRA_DIST = \
$(libcamel_extra_sources) \
README
+
+noinst_PROGRAMS = \
+ camel-folder-summary
+
+camel_folder_summary_SOURCES = \
+ camel-folder-summary.c
+
+camel_folder_summary_LDADD = \
+ ../camel/libcamel.la \
+ ../e-util/libeutil.la \
+ ../libibex/libibex.la \
+ $(GNOME_LIBDIR) \
+ $(GNOMEUI_LIBS) \
+ $(INTLLIBS) \
+ $(PTHREAD_LIB) \
+ $(EXTRA_GNOME_LIBS)
+