aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2002-11-05 17:05:24 +0800
committerMichael Zucci <zucchi@src.gnome.org>2002-11-05 17:05:24 +0800
commitc8b587d9c58dbb69085af3f05250f867be1c3631 (patch)
treee50e52c8a05afaafe9273fd311ac9fbb46483292 /camel/Makefile.am
parent46ad856f3d01c6dcaed6f283b5ca8b3aaaa67080 (diff)
downloadgsoc2013-evolution-c8b587d9c58dbb69085af3f05250f867be1c3631.tar
gsoc2013-evolution-c8b587d9c58dbb69085af3f05250f867be1c3631.tar.gz
gsoc2013-evolution-c8b587d9c58dbb69085af3f05250f867be1c3631.tar.bz2
gsoc2013-evolution-c8b587d9c58dbb69085af3f05250f867be1c3631.tar.lz
gsoc2013-evolution-c8b587d9c58dbb69085af3f05250f867be1c3631.tar.xz
gsoc2013-evolution-c8b587d9c58dbb69085af3f05250f867be1c3631.tar.zst
gsoc2013-evolution-c8b587d9c58dbb69085af3f05250f867be1c3631.zip
Created temporary link list, we need to link with something for gettext.
2002-11-05 Not Zed <NotZed@Ximian.com> * Makefile.am (camel_lock_helper_LDADD): Created temporary link list, we need to link with something for gettext. * camel.h: Remove gstring-util.h and hash-table-utils.h. * camel-text-index.c: (text_index_normalise): Changed for g_utf8_strdown api change. * camel-search-private.c: * camel-mime-utils.c: * camel-mime-part-utils.c: * camel-html-parser.c: * camel-charset-map.c: Include glib/gunicode.h from glib instead of gal. * camel-filter-driver.c: Remove include of gtk/gtk.h, should never have been there. svn path=/trunk/; revision=18542
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 7b6b45e0e5..e6e9064b73 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -230,13 +230,18 @@ camel_lock_helper_SOURCES = \
camel-lock.c \
camel-lock.h
+# NOTE: This needs to be cleaned up, it shouldn't link with all this crap,
+# because it might be setuid.
+camel_lock_helper_LDADD = \
+ $(libcamel_la_LIBADD)
+
camel_index_control_SOURCES = \
camel-index-control.c
camel_index_control_LDADD = \
$(libcamel_la_LIBADD) \
- libcamel.la \
- $(EVOLUTION_MAIL_LIBS)
+ libcamel.la
+# $(EVOLUTION_MAIL_LIBS)
install-exec-hook:
@if test -n "$(CAMEL_LOCK_HELPER_USER)"; then \