aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2001-07-12 13:02:11 +0800
committerMichael Zucci <zucchi@src.gnome.org>2001-07-12 13:02:11 +0800
commitb88f6b9593ad0a6fda85ca8d01b623583f714bcc (patch)
treee09fdaf2a329a81f097f932efd050977239783dd /camel/Makefile.am
parent421aa80ae6961cb4ddef8e79133ce89fcfbbf52d (diff)
downloadgsoc2013-evolution-b88f6b9593ad0a6fda85ca8d01b623583f714bcc.tar
gsoc2013-evolution-b88f6b9593ad0a6fda85ca8d01b623583f714bcc.tar.gz
gsoc2013-evolution-b88f6b9593ad0a6fda85ca8d01b623583f714bcc.tar.bz2
gsoc2013-evolution-b88f6b9593ad0a6fda85ca8d01b623583f714bcc.tar.lz
gsoc2013-evolution-b88f6b9593ad0a6fda85ca8d01b623583f714bcc.tar.xz
gsoc2013-evolution-b88f6b9593ad0a6fda85ca8d01b623583f714bcc.tar.zst
gsoc2013-evolution-b88f6b9593ad0a6fda85ca8d01b623583f714bcc.zip
Removed. (check_html_charset): Replaced with this.
2001-07-12 Not Zed <NotZed@Ximian.com> * camel-mime-part-utils.c (extract_metatag_charset): Removed. (check_html_charset): Replaced with this. (simple_data_wrapper_construct_from_parser): Call check_html_charset if we dont have a charset on the content-type, and we have text/html data. (check_html_charset): We also need to do qp/base64 decoding ourselves, sigh. * camel-mime-utils.c (html_meta_param_list_decode): Removed. This was very wrong, the rules for mail headers vastly different from rules for decoding html elements. (rfc2184_decode): Move the malloc inside the iconv_open worked, otherwise we have a memleak. * camel-mime-filter-html.c (camel_mime_filter_html_finalize, init, run, reset): Changed to use camelhtmlparser, and fixed a tiny memleak. * camel-html-parser.c: Made the html indexer tokeniser re-usable. ONLY TO BE USED INTERNAL TO CAMEL HOWEVER. (tokenise_step): Slight fix to non-quoted values. svn path=/trunk/; revision=11028
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index e8e0253efb..408a0e33d0 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -39,6 +39,7 @@ libcamel_la_SOURCES = \
camel-folder-summary.c \
camel-folder-thread.c \
camel-folder.c \
+ camel-html-parser.c \
camel-internet-address.c \
camel-lock.c \
camel-lock-client.c \
@@ -217,7 +218,8 @@ noinst_HEADERS = \
camel-charset-map-private.h \
camel-private.h \
camel-search-private.h \
- camel-lock-helper.h
+ camel-lock-helper.h \
+ camel-html-parser.h
# manually include camel-lock-helper.c since we build it manually
EXTRA_DIST = \