aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2001-01-25 10:04:28 +0800
committerMichael Zucci <zucchi@src.gnome.org>2001-01-25 10:04:28 +0800
commit1a403012d41b1619f4d946921184425b62b322a9 (patch)
tree9333080e02ad4ea5be28aad1e6fd9300013e9027 /camel/Makefile.am
parent7ad01f8ebef4b1e297a623c2015424d330da5958 (diff)
downloadgsoc2013-evolution-1a403012d41b1619f4d946921184425b62b322a9.tar
gsoc2013-evolution-1a403012d41b1619f4d946921184425b62b322a9.tar.gz
gsoc2013-evolution-1a403012d41b1619f4d946921184425b62b322a9.tar.bz2
gsoc2013-evolution-1a403012d41b1619f4d946921184425b62b322a9.tar.lz
gsoc2013-evolution-1a403012d41b1619f4d946921184425b62b322a9.tar.xz
gsoc2013-evolution-1a403012d41b1619f4d946921184425b62b322a9.tar.zst
gsoc2013-evolution-1a403012d41b1619f4d946921184425b62b322a9.zip
Changed the subject search to handle case sensitive when it is mixed case.
2001-01-25 Not Zed <NotZed@Ximian.com> * tests/folder/test3.c: Changed the subject search to handle case sensitive when it is mixed case. * Makefile.am (libcamel_la_SOURCES): Added camel-ssearch-private.c (noinst_HEADERS): Added camel-search-private.h * camel-folder-search.c (check_header): New function to do the work of the various header checks. (search_header_matches): (search_header_starts_with): (search_header_ends_with): (search_header_contains): Use check_header to do the work. (build_match_regex): Removed. * camel-search-private.c (header_soundex): New function to match words to phrases using soundex algorithm. * camel-filter-search.c (soundexcmp): Removed. (check_match): Moved to search-private.h 2001-01-24 Not Zed <NotZed@Ximian.com> * camel-search-private.c (camel_search_build_match_regex): Added extra flags, so the same function can be used for start/end/whole/partial matches. (camel_search_header_match): Convenience function to check a single header against all sorts of different matches. * providers/imap/camel-imap-search.c (imap_body_contains): Fix for e_sexp api changes. * camel-folder-search.c: Fix for e_sexp api changes. (search_header_contains): Free args/quit on unknown header. (search_header_matches): " (search_header_starts_with): " (search_header_ends_with): " (match_message): Add an exception argument. (search_body_contains): Free args/quit on fatal error. (message_body_contains): Removed (moved to camel-search-private.c), fixed callers. * camel-filter-search.c: Fix for e_sexp api changes. (build_match_regex, message_body_contains): Moved into camel-filter-private.c Fixed callers. (check_header): moved guts to camel-search-private, and changed to use regex's for everything. Just calls that with the right args. (check_header): GEts the header, decodes it, and checks for failure, and whatnot. (check_match): Removed. (header_soundex): Changed significantly. Now it soundexes each word in the header separately, and compares it to the first argument. * tests/folder/test9.c (main): Fix for api changes. (main): Added tests to see that invalid match and action rules are properly detected. * camel-filter-driver.c (camel_filter_driver_filter_mbox): Remove the 'finished message' bit. (camel_filter_driver_filter_message): Remove an accidentally checked in debug. (camel_filter_driver_filter_message): Fix for e-sexp api changes. svn path=/trunk/; revision=7796
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 8564db65d5..063ec03f08 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -48,6 +48,7 @@ libcamel_la_SOURCES = \
camel-object.c \
camel-provider.c \
camel-remote-store.c \
+ camel-search-private.c \
camel-seekable-stream.c \
camel-seekable-substream.c \
camel-service.c \
@@ -130,7 +131,8 @@ libcamel_la_LIBADD = $(top_builddir)/e-util/libeutil.la $(UNICODE_LIBS)
noinst_HEADERS = \
camel-charset-map-private.h \
- camel-private.h
+ camel-private.h \
+ camel-search-private.h
EXTRA_DIST = \
README