aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2001-03-14 15:06:54 +0800
committerMichael Zucci <zucchi@src.gnome.org>2001-03-14 15:06:54 +0800
commit0e9c0268a8ae99b88d7b98539181c0e938e5cb53 (patch)
tree448e5a9d7b6797e4a396c942a8370c5db2a99540 /camel/Makefile.am
parent83b4aa2b1d586cd9014394343b303d71e31ad3b8 (diff)
downloadgsoc2013-evolution-0e9c0268a8ae99b88d7b98539181c0e938e5cb53.tar
gsoc2013-evolution-0e9c0268a8ae99b88d7b98539181c0e938e5cb53.tar.gz
gsoc2013-evolution-0e9c0268a8ae99b88d7b98539181c0e938e5cb53.tar.bz2
gsoc2013-evolution-0e9c0268a8ae99b88d7b98539181c0e938e5cb53.tar.lz
gsoc2013-evolution-0e9c0268a8ae99b88d7b98539181c0e938e5cb53.tar.xz
gsoc2013-evolution-0e9c0268a8ae99b88d7b98539181c0e938e5cb53.tar.zst
gsoc2013-evolution-0e9c0268a8ae99b88d7b98539181c0e938e5cb53.zip
re-constify inbuf, to remove a warning.
2001-03-14 Not Zed <NotZed@Ximian.com> * camel-mime-filter-charset.c (filter, complete): re-constify inbuf, to remove a warning. * camel-mime-parser.c (folder_scan_step): When we're out of data, run the filter_complete. For some reason the logic that was there was never being run, always try it now, i think it was to work around a buggy filter, rather than fix it the right way. * camel-folder-summary.c (summary_build_content_info): If indexing html parts, use the html filter to convert it to some indexable format. (summary_build_content_info): Reset the filters before adding them back to the stream, if they get re-used in a given instance (likely). * Makefile.am (libcamelinclude_HEADERS): Added camel-mime-filter-html.[ch]. (INCLUDES): Added xml clags 2001-03-05 Not Zed <NotZed@Ximian.com> * camel-folder-search.c (camel_folder_search_class_init): Setup a new function, "uid" which matches uids. (search_uid): Implement the "match uid" command. svn path=/trunk/; revision=8705
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 857b8df246..d054ae1538 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -11,6 +11,7 @@ INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
-I$(top_srcdir)/intl \
-I$(top_srcdir)/e-util \
$(GLIB_CFLAGS) \
+ $(GNOME_XML_CFLAGS) \
$(UNICODE_CFLAGS) \
$(KRB4_CFLAGS) \
-DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
@@ -35,6 +36,7 @@ libcamel_la_SOURCES = \
camel-mime-filter-charset.c \
camel-mime-filter-crlf.c \
camel-mime-filter-from.c \
+ camel-mime-filter-html.c \
camel-mime-filter-index.c \
camel-mime-filter-linewrap.c \
camel-mime-filter-save.c \
@@ -103,6 +105,7 @@ libcamelinclude_HEADERS = \
camel-mime-filter-charset.h \
camel-mime-filter-crlf.h \
camel-mime-filter-from.h \
+ camel-mime-filter-html.h \
camel-mime-filter-index.h \
camel-mime-filter-linewrap.h \
camel-mime-filter-save.h \